Showing questions tagged: Show all questions

Location not blocked.

I use Firefox with a VPN. I also use the Chameleon extension to alter my fingerprint. When I log into Messenger.com it asks if this is me and gives my actual, physical lo… (read more)

I use Firefox with a VPN. I also use the Chameleon extension to alter my fingerprint. When I log into Messenger.com it asks if this is me and gives my actual, physical location. I've checked in settings under location and it doesn't show any sites requesting my location. I have it open in one of the tabs where it's showing my location. I have block all location requests checked. How can I get Firefox to not show my physical location?

Also on this page, it gives I'm using Firefox and the OS I'm using. Both are supposed to be changed for fingerprinting protection.

This looks like it could be a big security loophole. Any help is appreciated.

Asked by 95rhino404 23 hours ago

HSTS cookies

OK, I have Firefox (Windows 10 AMD64, desktop) configured to delete history when I close it. So, I see that regular webiste cookies are deleted. But are the HSTS websit… (read more)

OK, I have Firefox (Windows 10 AMD64, desktop) configured to delete history when I close it.

So, I see that regular webiste cookies are deleted.

But are the HSTS website "super cookies" deleted?

https://ipleak.com/articles/what-is-hsts-super-cookies What are HSTS Super cookies and why are they dangerous?


thanx.

Asked by TooFar 2 days ago

Open a new tab, cannot copy text

When I click on a link and say to open the link in a new tab, there's an issue. The "Copy" in the context menu for that new tab is grayed out, i.e., cannot be selected. … (read more)

When I click on a link and say to open the link in a new tab, there's an issue.

The "Copy" in the context menu for that new tab is grayed out, i.e., cannot be selected.

So I have to go back to the origin page, and then re-select the new, just opened tab.

After I do that, the "Copy" is no longer grayed out.

Is this a bug?

If so, how do I report it?

Many thanks.

Asked by TooFar 2 days ago

Credit Card autofill breaks after system reboot

Similar to this problem: https://support.mozilla.org/en-US/questions/1360287 . I am using Debian 12, i3wm, and Firefox 127.0.1 After adding a new credit card to Firefox… (read more)

Similar to this problem: https://support.mozilla.org/en-US/questions/1360287 .

I am using Debian 12, i3wm, and Firefox 127.0.1

After adding a new credit card to Firefox, I can go to any website that needs credit card info and it will auto fill successfully. When I reboot my computer and then try to auto fill credit card info, Firefox prompts me for the password to the "Default" keyring, but it does not autofill (something in the input box flashes quickly then it goes blank again). Firefox will not autofill again until I add a new credit card.

I had no success with Firefox in Troubleshooting mode either.

Asked by crawforc3@gmail.com 3 days ago

OCSP querying despite being disabled

Good day, I was experiencing a time related issue when my system clock was unexpectedly lagging behind. I was trying to connect to my https proxy while noticing. I had d… (read more)

Good day,

I was experiencing a time related issue when my system clock was unexpectedly lagging behind. I was trying to connect to my https proxy while noticing. I had disabled ocsp querying and hard-fail to avoid any issues. So far, nothing was out of the ordinary. What really surprised me however, was that i was getting the OCSP_FUTURE_RESPONSE error all of a sudden. It should have never attempted querying the ocsp server in the first place. why then am i getting this error message?

Asked by Flin234 3 days ago

Firefox pauses video (when playing videos from the web) whenever audio is NOT muted.

Pretty much every video I attempt to play, including https://www.allaboutbirds.org/cams/red-tailed-hawks/# will play the video only when audio is muted. unmute the audio … (read more)

Pretty much every video I attempt to play, including https://www.allaboutbirds.org/cams/red-tailed-hawks/# will play the video only when audio is muted. unmute the audio and you get the audio track but the video is paused.

Can't figure this one out, I've seen it only in the last few days (it started when I was using 127.0.0 and continues in 127.0.1)

Chrome and Chromium don't do this.

Thanks in advance for any helpful advice!

Fred

Asked by fredex 4 days ago

Open With pop-up window not showing

Hello, I've recently installed 127.0 (64-bit) and although I've set browser.download.start_downloads_in_tmp_dir to true, and rebooted my PC, I still don't get the 'Open … (read more)

Hello,

I've recently installed 127.0 (64-bit) and although I've set browser.download.start_downloads_in_tmp_dir to true, and rebooted my PC, I still don't get the 'Open With' pop-up - the file goes directly into Downloads.

I'm on Ubuntu 22.04 LTS (jammy jellyfish).

Please advise me what I'm doing wrong.

Asked by chris.leake 5 days ago

Context Menu, 7th item cannot open in New Tab

When I open a bookmark folder and right-click on the 7th item down I cannot select Open in New Tab because the context menu is jammed up against the top of the screen (I … (read more)

When I open a bookmark folder and right-click on the 7th item down I cannot select Open in New Tab because the context menu is jammed up against the top of the screen (I believe it is called the Title Bar where resides the date and some of the system menus,) and the Open in New Tab at the top of the context menu is present, will not highlight and cannot be selected with the mouse.

FF 126.0.1 Host: Laptop AB BIOS: INSYDE Corp. 3.19 (05/29/2023) OS: Pop!_OS 22.04 LTS x86_64 DE: GNOME 42.9 (x11) Kernel: Linux 6.8.0-76060800daily20240311-generic Shell: bash 5.1.16

Asked by qpackard 6 days ago

Last reply by qpackard 5 days ago

Firefox : Could not load xpcom

Hello, I am currently facing a problem. Yesterday, I passed a message from https://firefox-source-docs.mozilla.org/setup/linux_build.html#building ---The official documen… (read more)

Hello, I am currently facing a problem. Yesterday, I passed a message from https://firefox-source-docs.mozilla.org/setup/linux_build.html#building ---The official documentation for firefox on Linux compiles and installs a Linux system with aarch64 architecture on an Ubuntu host with x86 architecture. In fact, I only modified a file called ". mozconfig" and added the following information: "ac-add-options -- target=aarch64-linux-gnu mk-add-options MOZ-OBJDIR=@TOPSRCDIR@/obj-aarch64-linux mk-add-options AUTOCLOBBER=1". After compiling for a while, I obtained a folder called "obj-aarch64-linux". I used the command "file /obj-aarch64-linux/dist/bin/firefox" to check the properties of the knowability file as follows: " firefox: ELF 64 bit LSB shared object, ARM aarch64, version 1 (SYSV), dynamically linked, interpreter/lib/ld Linux arch64. so. 1, for GNU/Linux 3.7.0, BuildID [md5/uuid]=6b1bede035b0d0bc9930d0d4d88c3c14, with debug_info, not stripped ”. I think I have completed cross compilation, so I compressed the "obj-aarch64-linux" folder on a USB drive and copied it to my aarch64 architecture development board. And when I tried to launch the browser on the development board using the "./obj-aarch64-linux/dist/bin/firefox" command, I received an error message saying "Couldn't load XPCOM". It is worth mentioning that firefox is installed by default on my development board, but I need to compile and install its source code, and local compilation cannot be achieved on my development board, so I made the above operation. So, I want to know how to solve this problem, or if there are any errors in my cross compilation process. Thank you for your help and look forward to your prompt reply.

Asked by 158107824 6 days ago