Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

No middle-click navigation

more options

Hi, it has been a while that one of the updates on firefox removed the ability to navigate using the middle click, i waited and waited for some day an update drop and fix that but it's been a while and nothing has come, i was sure to test this on another computer and it didn't worked as well so i'm pretty sure firefox has some problems, i mainly use a drawing tablet because i don't have a mouse, so navigating is a bit hard without the usual middle click nagivation(i'm not sure if there is an actual name to that), please help

Hi, it has been a while that one of the updates on firefox removed the ability to navigate using the middle click, i waited and waited for some day an update drop and fix that but it's been a while and nothing has come, i was sure to test this on another computer and it didn't worked as well so i'm pretty sure firefox has some problems, i mainly use a drawing tablet because i don't have a mouse, so navigating is a bit hard without the usual middle click nagivation(i'm not sure if there is an actual name to that), please help

Chosen solution

Autoscrolling?

https://support.mozilla.org/en-US/kb/mouse-shortcuts-perform-common-tasks#w_autoscrolling-a-page

Have to make sure “Use autoscrolling” is enabled in the Settings in Firefox.

Read this answer in context 👍 0

All Replies (3)

more options

Can you clarify what you mean with middle-click navigation ? What are you trying to accomplish with this middle-click ? Does holding Ctrl and left-clicking work?

Is the other computer also a tablet or does that device has a mouse attached?

Helpful?

more options

Chosen Solution

Autoscrolling?

https://support.mozilla.org/en-US/kb/mouse-shortcuts-perform-common-tasks#w_autoscrolling-a-page

Have to make sure “Use autoscrolling” is enabled in the Settings in Firefox.

Helpful?

more options

James said

Autoscrolling? https://support.mozilla.org/en-US/kb/mouse-shortcuts-perform-common-tasks#w_autoscrolling-a-page Have to make sure “Use autoscrolling” is enabled in the Settings in Firefox.

damn so firefox just randomly turned that off on me during an update and i never got to know how and why, truly amazing, thanks for telling me

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.