Avatar for Username

Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

Suddenly unable to connect to outgoing mail server

  • 17 ответов
  • 1 имеет эту проблему
  • 1 просмотр
  • Последний ответ от David Salerno

more options

I've just started getting error messages that I need to enter my password to send emails. I've tried that but it still keeps saying unable to connect to the server. This has been happening for about two days now. I've tried updating Thunderbird, restarting Thunderbird and restarting my PC. None of this has worked. I made no changes to my system, software or home network. Any help would be appreciated. Thanks, Dave

I've just started getting error messages that I need to enter my password to send emails. I've tried that but it still keeps saying unable to connect to the server. This has been happening for about two days now. I've tried updating Thunderbird, restarting Thunderbird and restarting my PC. None of this has worked. I made no changes to my system, software or home network. Any help would be appreciated. Thanks, Dave

Все ответы (17)

more options

Please post screenshot of of the SMTP server settings pane. That may cause some ideas to surface.

Полезно?

more options

Thanks for responding. I've attached a couple of screen shots of the server setting, and the outgoing server setting.

You may notice that there are two accounts with the same name - except I added "temp" to the end of one. This happened months ago, when I built a new PC and imported the saved data from my Thunderbird account. Somehow it ended up creating a new Indbox and set of folders that got all of my new mail. I kept the old one because I wasn't sure how that happened and was a bit afraid to delete it all.

But this had been working for months, so I believe it's not directly related to my issue that just occurred about two days ago, where I get constant error window pop-ups and have not been receiving new mail.

For now I've created a new Outlook account, which is what I'm using to send this. It seems to be working, and got your email just now, which Thunderbird did not.

Thanks so much for your help. I've got a ton of folders with years worth of previous emails, all organized in Thunderbird and it doesn't appear that I can easily transfer them to Outlook, so I'd really like to get that working again.

Dave

Полезно?

more options

I may not be able to help; my request for the SMTP seIttings is that, without that, nobody can assist. I did check the comcast web site and it suggests there to use port 587. You might also check the settings on Outlook to see if they're different.

Полезно?

more options

I'm sorry, I guess I don't know what other settings to send a shot of. One of the pics I attached was for the SMTP settings. Was this not what you needed to see?

Полезно?

more options

It was exactly what I requested, as anyone attempting to help would want that info. I did see that it's on port 465 and the comcast site indicated 587 was preferred. That's all I know.

Полезно?

more options

OK, thanks anyway. It looks like I'm an Outlook user now :-(

I did try changing the port number as you suggested, but it hasn't helped.

Полезно?

more options

It looks like you are using 'Authentication Method' = OAuth2 which means entering a Normal Password is never going to be accepted because server expects the Oauth token.

You would need to remove all stored passwords. REstart Thunderbird and it will prompt you to logon to prove you really are you and then a new Oauth token will get uploaded and stored in Thunderbird. Thunderbird will then continue to use the token.

Alternative : stop using Oauth for incoming and outgoing and use 'Authentication Method' = 'Normal Password' instead for both. Remove stored passwords REstart Thunderbird and at prompt enter the normal password - same one you use to access webmail - remember to select the checkbox to remember passwords.

Полезно?

more options

Thanks - I'll try using Normal Password. I didn't know the difference between these, and don't remember choosing them.

Полезно?

more options

I tried clearing the passwords and using both Normal Password and Oauth2, but I had no luck. A window pops up, but it's blank and there is no way to enter a password. ??? Thanks for trying to help.

Полезно?

more options

The window that pops up will be the oauth authentication window I would guess. Based entirely on past interactions with oauth.

The blank web page is something I have seen reported in this forum in the past but have no "this is the cause" solution. Some things to check however which might be the cause.

  1. Do you use a passkey or access method like two factor authentication to access your account using webmail?
  2. Is Thunderbird's ability to use JavaScript in a web context disabled? Use the Config Editor to check that the preference javascript.enabled is set to true. This is the default, but some folk disable it in the interests of security (I don't understand it but they do.) and occasionally "security" software does it for them.
  3. Is thunderbird ability to accept cookies compromised? Search in settings for cookies and ensure the setting to accept cookies from site is enabled.

Изменено Matt

Полезно?

more options

Thanks for the suggestions Matt.

1. I don't have a passkey or 2 factor authentication setup for it. 2. I'm sorry, I didn't have any luck opening the config editor link. It took me to a page for creating a new Mozilla article?? I don't know enough about this to have changed the setting, haha. But it does seem like something is preventing the window that pops up from loading properly. Would it have anything to do with my browser settings? I don't know what program is being used for this pop-up window (Thunderbird, Firefox, ...?) 3. I do have cookies enabled.

I haven't tried contacting Comcast to see if they might be able to help - maybe they changed something? It's just that I'd rather have a root canal than to try and contact a human at Comcast.

Полезно?

more options

I have no idea what the forum software managed to do with that link. I just edited it to exactly the same thing and it now apparently works.

But for clarity the article is here https://support.mozilla.org/en-US/kb/config-editor

While the page that loads in Thunderbird is a browser page, it is a Thunderbird browser page. Under the hood Thunderbird has access to almost all of the features of the Firefox browser because it is built on the same underlying Mozilla platform. In these instances Thunderbird launches as a browser and handles the transaction, so looking at your default browser will not be helpful.

So check on the javascript stuff and I will see if I can get someone that has also reported the issue to chime in.

Полезно?

more options

Thanks again Matt. I checked that and it is enabled. Ugh, this is so strange. It's worked fine for years, which is why I wonder if Comcast changed something that requires me to do something.

Полезно?

more options

It looks to me like they started requiring oauth authentication. It did not used to be available.

Полезно?

more options

Would it help (or be a bad idea) to specify something else, like "Normal"?

Thanks

Полезно?

more options

Assuming you have:

  • switched off any server side 2 step verification via a browser.
  • Set Thunderbird up to use 'Authentication Method = Oauth2'
  • Cleared out all stored passwords in Thunderbird.
  • Set Thunderbird Settings to enable and allow cookies.
  • Checked Config Editor in Thunderbird to ensure javascript is enabled.

A yahoo window which asks for your password and it's blank sounds like it might mean it cannot use the 'localhost'.

Maybe you have been developing a website. Do you have something using the localhost eg: XAMPP Apache ?

If yes, then switch if off until the OAuth2 has been set up.

Do you have a VPN enabled ? Please double check because I discovered Norton had auto enabled it on my computer. If yes, then switch it off because servers might think someone is trying to access your account.

Some images attached to help guide you.

  • How to find 'Config Editor'.
  • check that the preference javascript.enabled is set to true.
  • Settings - enable cookies

Полезно?

more options

I don't have a VPN, and I have my settings like the ones in your pics.

I still haven't gotten around to checking with Comcast, since I hate them so much.

I've come to accept that I may have to stick with Outlook, or some other program. Unfortunately I am now being inundated with junk mail that I never got before, all with an Outlook address. WTH!

Полезно?

Задать вопрос

Для ответа на сообщения вы должны войти в свою учётную запись. Пожалуйста, задайте новый вопрос, если у вас ещё нет учётной записи.