Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

Dont know why some pages shows me in russian language

  • 12 ответов
  • 0 имеют эту проблему
  • Последний ответ от zeroknight

more options

Hello. I have put my language everywhere on the settings which is latvian. For possible translations i have only put english. Some pages, for example, whatsapp web is showing in russian ( i mean the app data for sure, not the messages), also some homepages i use open automatically in russian. How can i put latvian by default or if its not available for the homepage, put english automatically?

Hello. I have put my language everywhere on the settings which is latvian. For possible translations i have only put english. Some pages, for example, whatsapp web is showing in russian ( i mean the app data for sure, not the messages), also some homepages i use open automatically in russian. How can i put latvian by default or if its not available for the homepage, put english automatically?

Все ответы (12)

more options

Yes, go to Settings -> General -> Language -> Choose your preferred language for displaying pages -> press the Choose… button.

Полезно?

more options

The thing is i already have put latvian there and not russian, but still some pages show russian

Полезно?

more options

Try to put English there on a 2nd place.

Полезно?

more options

have already did that, 1st language latvian and 2nd english.. cant seem to find any place with russian language at my settings

Полезно?

more options

Language may be decided based on the location of your IP address. Check IP location and try using a VPN or proxy located elsewhere.

Полезно?

more options

my ip address is in Latvias capital, Riga, and not any russian ip, so thats not the case

Полезно?

more options

Does it still happen with default settings in a new browser profile? An easy way to test a new profile is to install Developer Edition and see if it happens there or refresh your existing profile. Make sure you stay signed out of your sync account when testing.

Полезно?

more options

thanks! at developer edition it shows how it should. what should i do now?

Полезно?

more options

You can remove all data stored in Firefox for a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History").

Using "Forget About This Site" will remove all data stored in Firefox for this domain like history and cookies and passwords and exceptions and cache, so be careful. If you have a password or other data for that domain that you do not want to lose, make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of involved files.

If you revisit a 'forgotten' website, data for that website will be saved once again.

Полезно?

more options

If you want to fix your profile instead of simply refreshing it, you will need to find the issue through a process of elimination.

Backup your profile folder and try resetting all about:config settings to default by renaming the prefs.js file while Firefox is not running.

Полезно?

more options

Note that you lose extension data if you rename/remove prefs.js, you can copy the extensions.webextensions.uuids line to the new prefs.js to recover extension data.

Полезно?

more options

It would be better to restore from the backup once the issue has been identified.

Полезно?

Задать вопрос

Для ответа на сообщения вы должны войти в свою учётную запись. Пожалуйста, задайте новый вопрос, если у вас ещё нет учётной записи.