Cari Bantuan

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Pop-up blocked

  • 17 balas
  • 0 memiliki masalah ini
  • 1 kunjungan
  • Balasan terakhir oleh cor-el

more options

My Firefox is the most recent version 126. I am having trouble with pop-ups being blocked. I have added the website to the pop-up exception list. When I go to the site, it shows me the little icon showing I have added exceptions for this site. However; the pop-up still gets blocked.

The site is: https://www.foxit.com/ I try clicking the Log In drop down then Foxit Account. Before this would pop-up the log in screen for the site but since version 125, it does not. I just updated to version 126 to see if that resolved it before creating this post but it didn't. Thus I am here trying to get help.

My Firefox is the most recent version 126. I am having trouble with pop-ups being blocked. I have added the website to the pop-up exception list. When I go to the site, it shows me the little icon showing I have added exceptions for this site. However; the pop-up still gets blocked. The site is: https://www.foxit.com/ I try clicking the Log In drop down then Foxit Account. Before this would pop-up the log in screen for the site but since version 125, it does not. I just updated to version 126 to see if that resolved it before creating this post but it didn't. Thus I am here trying to get help.
Lampiran tangkapan layar

Semua Balasan (17)

more options

Hi Kevin, this popup doesn't actually require an exception because it is generated directly after you click a menu item on the site. So it is strange that you don't get that window

If JavaScript was completely disabled, after you click the menu item, a # would be added to the URL in the address bar. I don't see that in your screenshot, so it's probably not an issue with scripts being blocked.

Could you open the Web Console in the tab with the main page, using Ctrl+Shift+K. You can click the trash can icon at the upper left to clear the existing messages. Then, after trying the menu item again, do any new messages appear in the console?

Membantu?

more options

@jscher2000 - I tested that theory about the JavaScript. After I do click the Foxit Account it does append an # to the end of the URL. Based on your response I take it JavaScript is disabled. Is there a way to add an exception for that so JavaScript can run on this site?

Membantu?

more options

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or if userChrome.css/userContent.css is causing the problem.

  • switch to the Default System theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window

Membantu?

more options

Troubleshoot Mode did not work. The site still does not function when using that mode. I believe @jscher2000 was on the right track.

jscher2000 - Support Volunteer said

If JavaScript was completely disabled, after you click the menu item, a # would be added to the URL in the address bar. I don't see that in your screenshot, so it's probably not an issue with scripts being blocked.

Why would JavaScript be disabled for this site though? I checked the about:config in the address bar and the preference javascript.enabled equals True.

Membantu?

more options

If it helps, I followed @jscher2000 steps about Ctrl-Shift-K and attached are its messages.

Some cookies are misusing the recommended “SameSite“ attribute 15 This page uses the non standard property “zoom”. Consider using calc() in the relevant property values, or using “transform” along with “transform-origin: 0 0”. www.foxit.com Cookie “D41ID” will soon be rejected because it is foreign and does not have the “Partitioned“ attribute. sync Cookie “D41IDT” will soon be rejected because it is foreign and does not have the “Partitioned“ attribute. sync Script from “https://id.rlcdn.com/712087.gif?cparams=c59091d6df0e4597919fb5dde57e256d-fb27e3732cf342df8a0e72d2f1767f33-1-723-paapi8916” was blocked because of a disallowed MIME type (“image/gif”). www.foxit.com Uncaught ReferenceError: foxitApp is not defined

   <anonymous> https://www.foxit.com/ line 1 > injectedScript:2
   activateScript https://www.foxit.com/cdn-cgi/scripts/7d0fa10a/cloudflare-static/rocket-loader.min.js:1
   n https://www.foxit.com/cdn-cgi/scripts/7d0fa10a/cloudflare-static/rocket-loader.min.js:1
   run https://www.foxit.com/cdn-cgi/scripts/7d0fa10a/cloudflare-static/rocket-loader.min.js:1
   n https://www.foxit.com/cdn-cgi/scripts/7d0fa10a/cloudflare-static/rocket-loader.min.js:1
   s https://www.foxit.com/cdn-cgi/scripts/7d0fa10a/cloudflare-static/rocket-loader.min.js:1
   u https://www.foxit.com/cdn-cgi/scripts/7d0fa10a/cloudflare-static/rocket-loader.min.js:1
   n https://www.foxit.com/cdn-cgi/scripts/7d0fa10a/cloudflare-static/rocket-loader.min.js:1
   run https://www.foxit.com/cdn-cgi/scripts/7d0fa10a/cloudflare-static/rocket-loader.min.js:1
   n https://www.foxit.com/cdn-cgi/scripts/7d0fa10a/cloudflare-static/rocket-loader.min.js:1
   s https://www.foxit.com/cdn-cgi/scripts/7d0fa10a/cloudflare-static/rocket-loader.min.js:1
   u https://www.foxit.com/cdn-cgi/scripts/7d0fa10a/cloudflare-static/rocket-loader.min.js:1
   n https://www.foxit.com/cdn-cgi/scripts/7d0fa10a/cloudflare-static/rocket-loader.min.js:1
   run https://www.foxit.com/cdn-cgi/scripts/7d0fa10a/cloudflare-static/rocket-loader.min.js:1
   n https://www.foxit.com/cdn-cgi/scripts/7d0fa10a/cloudflare-static/rocket-loader.min.js:1
   s https://www.foxit.com/cdn-cgi/scripts/7d0fa10a/cloudflare-static/rocket-loader.min.js:1
   u https://www.foxit.com/cdn-cgi/scripts/7d0fa10a/cloudflare-static/rocket-loader.min.js:1
   n https://www.foxit.com/cdn-cgi/scripts/7d0fa10a/cloudflare-static/rocket-loader.min.js:1
   run https://www.foxit.com/cdn-cgi/scripts/7d0fa10a/cloudflare-static/rocket-loader.min.js:1
   x https://www.foxit.com/cdn-cgi/scripts/7d0fa10a/cloudflare-static/rocket-loader.min.js:1
   runOnLoad https://www.foxit.com/cdn-cgi/scripts/7d0fa10a/cloudflare-static/rocket-loader.min.js:1
   runOnLoad https://www.foxit.com/cdn-cgi/scripts/7d0fa10a/cloudflare-static/rocket-loader.min.js:1
   x https://www.foxit.com/cdn-cgi/scripts/7d0fa10a/cloudflare-static/rocket-loader.min.js:1
   <anonymous> https://www.foxit.com/cdn-cgi/scripts/7d0fa10a/cloudflare-static/rocket-loader.min.js:1
   <anonymous> https://www.foxit.com/cdn-cgi/scripts/7d0fa10a/cloudflare-static/rocket-loader.min.js:1
   <anonymous> https://www.foxit.com/cdn-cgi/scripts/7d0fa10a/cloudflare-static/rocket-loader.min.js:1

line 1 > injectedScript:2:9 Uncaught ReferenceError: $ is not defined

   <anonymous> https://www.foxit.com/ line 1 > injectedScript:33
   activateScript https://www.foxit.com/cdn-cgi/scripts/7d0fa10a/cloudflare-static/rocket-loader.min.js:1
   n https://www.foxit.com/cdn-cgi/scripts/7d0fa10a/cloudflare-static/rocket-loader.min.js:1
   run https://www.foxit.com/cdn-cgi/scripts/7d0fa10a/cloudflare-static/rocket-loader.min.js:1
   n https://www.foxit.com/cdn-cgi/scripts/7d0fa10a/cloudflare-static/rocket-loader.min.js:1
   s https://www.foxit.com/cdn-cgi/scripts/7d0fa10a/cloudflare-static/rocket-loader.min.js:1
   u https://www.foxit.com/cdn-cgi/scripts/7d0fa10a/cloudflare-static/rocket-loader.min.js:1
   n https://www.foxit.com/cdn-cgi/scripts/7d0fa10a/cloudflare-static/rocket-loader.min.js:1
   run https://www.foxit.com/cdn-cgi/scripts/7d0fa10a/cloudflare-static/rocket-loader.min.js:1
   n https://www.foxit.com/cdn-cgi/scripts/7d0fa10a/cloudflare-static/rocket-loader.min.js:1
   s https://www.foxit.com/cdn-cgi/scripts/7d0fa10a/cloudflare-static/rocket-loader.min.js:1
   u https://www.foxit.com/cdn-cgi/scripts/7d0fa10a/cloudflare-static/rocket-loader.min.js:1
   n https://www.foxit.com/cdn-cgi/scripts/7d0fa10a/cloudflare-static/rocket-loader.min.js:1
   run https://www.foxit.com/cdn-cgi/scripts/7d0fa10a/cloudflare-static/rocket-loader.min.js:1
   n https://www.foxit.com/cdn-cgi/scripts/7d0fa10a/cloudflare-static/rocket-loader.min.js:1
   s https://www.foxit.com/cdn-cgi/scripts/7d0fa10a/cloudflare-static/rocket-loader.min.js:1
   u https://www.foxit.com/cdn-cgi/scripts/7d0fa10a/cloudflare-static/rocket-loader.min.js:1
   n https://www.foxit.com/cdn-cgi/scripts/7d0fa10a/cloudflare-static/rocket-loader.min.js:1
   run https://www.foxit.com/cdn-cgi/scripts/7d0fa10a/cloudflare-static/rocket-loader.min.js:1
   n https://www.foxit.com/cdn-cgi/scripts/7d0fa10a/cloudflare-static/rocket-loader.min.js:1
   s https://www.foxit.com/cdn-cgi/scripts/7d0fa10a/cloudflare-static/rocket-loader.min.js:1
   u https://www.foxit.com/cdn-cgi/scripts/7d0fa10a/cloudflare-static/rocket-loader.min.js:1
   n https://www.foxit.com/cdn-cgi/scripts/7d0fa10a/cloudflare-static/rocket-loader.min.js:1
   run https://www.foxit.com/cdn-cgi/scripts/7d0fa10a/cloudflare-static/rocket-loader.min.js:1
   x https://www.foxit.com/cdn-cgi/scripts/7d0fa10a/cloudflare-static/rocket-loader.min.js:1
   runOnLoad https://www.foxit.com/cdn-cgi/scripts/7d0fa10a/cloudflare-static/rocket-loader.min.js:1
   runOnLoad https://www.foxit.com/cdn-cgi/scripts/7d0fa10a/cloudflare-static/rocket-loader.min.js:1
   x https://www.foxit.com/cdn-cgi/scripts/7d0fa10a/cloudflare-static/rocket-loader.min.js:1
   <anonymous> https://www.foxit.com/cdn-cgi/scripts/7d0fa10a/cloudflare-static/rocket-loader.min.js:1
   <anonymous> https://www.foxit.com/cdn-cgi/scripts/7d0fa10a/cloudflare-static/rocket-loader.min.js:1
   <anonymous> https://www.foxit.com/cdn-cgi/scripts/7d0fa10a/cloudflare-static/rocket-loader.min.js:1

Membantu?

more options

This works for me with browser.link.open_newwindow.restriction set to 2 (diverted to popup window) and with set to 0 (diverted to a new tab) and it issues openLoginWindow() Is this function defined if you paste openLoginWindow in the Web Console?

  • function openLoginWindow(from, force)

Boot the computer into Windows Safe Mode with network support to see if that has effect in case security software is blocking this popup.

Membantu?

more options

I set the browser.link.open_newwindow.restriction to 0 it was set to 2. When I search for openLoginWindow the value for that is True. But the log in screen still does not open in the new tab. I am not sure what you mean by

cor-el said

Is this function defined if you paste openLoginWindow in the Web Console?
  • function openLoginWindow(from, force)

Membantu?

more options

I probably should also mention that safe mode did not work since you mentioned that too.

Membantu?

more options

That second screenshot shows about:config. You need to check in the Web Console to is if openLoginWindow is defined.

Membantu?

more options

If I did this right, then it is not defined.

Membantu?

more options

You need to enter this in the command-line in the web console and not in the search/filter bar.

Membantu?

more options

Oh okay. Typing it there produces.

ReferenceError: openLoginWindow is not defined

Am I able to define it myself or is that an issue with the website?

Membantu?

more options

This means that the JavaScript that defines and handles this function is blocked.

Do you at least get a drop down panel with the choices if you hover the Login button ?

You can check the Network Monitor to see if content is blocked or otherwise fails to load.

If necessary use "Ctrl+F5" or "Ctrl+Shift+R" (Mac: Command+Shift+R) to reload the page and bypass the cache to generate a fresh log.

Membantu?

more options

I do get the drop down of panel choices when hooving over Log In. How can I unblock JavaScript for this page?

Membantu?

more options

Sorry, I just noticed that the # appears on the address bar even when the popup window for signing in opens successfully, so that isn't as much of a tell as I thought before. (Screenshot attached.)

Did the site lose permission to open popup windows? You can check using the Page Info dialog while you're on the site. Here's how:

  • Press Ctrl+i to open the Page Info dialog
  • Click Permission to switch panels
  • Scroll down to "Open pop-up windows"
  • Uncheck "Use default" and select Allow

More generally, I only got it to fail a couple times, after which reloading it made it work. So I don't know what is causing the problem.

Membantu?

more options

Sadly that already showed it was select to Allow. I even tried changing to Default then back again to Allow which didn't work either. I admit this is one weird issue I got going on.

Membantu?

more options

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or if userChrome.css/userContent.css is causing the problem.

  • switch to the Default System theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window

You can create a new profile as a quick test to see if your current profile is causing the problem.

See "Creating a profile":

If the new profile works, you can transfer files from a previously used profile to the new profile, but be careful not to copy corrupted files to avoid carrying over problems.

Membantu?

Ajukan pertanyaan

Anda harus masuk ke akun Anda untuk membalas kiriman ini. Sila mulai pertanyaan baru, jika Anda belum memiliki akun.