Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox is forcing Acrobat file to be saved, rather than opening it. How can this be fixed?

  • 5 ప్రత్యుత్తరాలు
  • 7 ఈ సమస్యలు కలిగి ఉన్నాయి
  • 133 వీక్షణలు
  • చివరి సమాధానమిచ్చినది rjkoda

more options

When I visit a website that has a .pdf file on it and I try to download the file, rather than opening up to be read, Firefox asks where it should be saved. It does not directly open the file for viewing as it had done last week. Thanks for any advice to address this problem.

When I visit a website that has a .pdf file on it and I try to download the file, rather than opening up to be read, Firefox asks where it should be saved. It does not directly open the file for viewing as it had done last week. Thanks for any advice to address this problem.

ప్రత్యుత్తరాలన్నీ (5)

more options
more options

This response did not solve the problem. When I go into the menu to change download actions for "Adobe Acobat Document", the drop-down menu to the right only contains: "always ask", "save file", "use Acrobat 8.1" and "use other"; it does not contain "Use Adobe Acrobat (in Firefox)" which is the indicated fix.

How can I put that last item into the drop down menu?

more options

There should be a Use other... item at the bottom of the "Action" list. Select Acrobat Reader from that "other" list.

more options

The only Acrobat related item in the "other" related list was the Acrobat 8.1 which I selected, but this selected item did not correct the problem.

more options

I finally found the right fix in the reset section of Check Firefox settings. I clicked on "Help" and clicked on "Troubleshooting Information". Under "Application Basics", I clicked on "Open Containing Folder". A window with my profile files opened. I selected the "mimetypes.rdf" file and deleted it. I then closed the Mozilla program, rebooted my computer and then reopened Mozilla Firefox. Voila - It returned "Use Adobe Acrobat (in Firefox)" in my settings. All is well.