Sök i support

Akta dig för supportbedrägerier: Vi kommer aldrig att be dig att ringa eller skicka ett sms till ett telefonnummer eller dela personlig information. Rapportera misstänkt aktivitet med alternativet "Rapportera missbruk".

Learn More

AVG 2017 causes Firefox to crash on Windows XP, any solution?

more options

Today's release and update of AVG 2017 has crashed Firefox. I can turn off AVG temporarily to recover Firefox. I can see that Firefox is active in the Task Manager but nothing is displayed, not even an error message. I have tried 3 other browsers to check its not an AVG issue and spoke with AVG Tech Support.

Today's release and update of AVG 2017 has crashed Firefox. I can turn off AVG temporarily to recover Firefox. I can see that Firefox is active in the Task Manager but nothing is displayed, not even an error message. I have tried 3 other browsers to check its not an AVG issue and spoke with AVG Tech Support.

Alla svar (10)

more options

I don't know whether this is an incompatibility with a particular feature of Avast 2017/Firefox, or something else. On Windows 10, there was recently an issue with Malwarebytes Exploit Protection and Firefox's Multiprocess feature. Could you check on whether that feature is a factor on your system:

Are you using Multiprocess (e10s)?

Multiprocess creates a second firefox.exe or plugin-container.exe process to isolate the web content from the browser UI. This might look suspicious to some security software or break Firefox with some sandboxes. You can check whether you have this feature turned on as follows. Either:

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter/Return

In the first table on the page, check the row for "Multiprocess Windows" and see whether the number on the left side of the fraction is greater than zero. If so, you are using e10s.

If you are using e10s:

To help evaluate whether that feature is causing problems, you could turn it off as follows:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste autos and pause while the list is filtered

(3) Double-click the browser.tabs.remote.autostart.2 preference to switch the value from true to false

Note: the exact name of the preference may vary, but it will start with browser.tabs.remote.autostart

At your next Firefox startup, it should run in the traditional way. Any difference?

more options

Try to start Firefox in Safe Mode to see if that works.

  • Windows: hold down the Shift key while starting Firefox
  • Mac: hold down the Options key while starting Firefox

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button# or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

more options

no safemode also doesn't work. only when AVG protection is deactivated.

more options

Jscher also there is only 1 Firefox running in Task Manager unless I open a second window.

more options

Aron_Davidson said

Jscher also there is only 1 Firefox running in Task Manager unless I open a second window.

Do you mean there is one instance of firefox.exe with one window and two with two windows?? That would be atypical and possibly indicate use of a startup switch to create multiple instances. But you might also be looking at a list of open windows rather than a list of processes. Anyway, the method I mentioned is the recommended way to check.

more options

ok changed browser.tabs.remote.autostart.2 to false and still same problem. There used to be plugin-container.exe but that may have changed with the recent Firefox update. Also at the moment there are multiple chrome processes evident in Task Manager.

more options

Aron_Davidson said

ok changed browser.tabs.remote.autostart.2 to false and still same problem.

Thank you for testing that. I don't know what AVG has against Firefox on your system. You may want to try a "clean reinstall" (steps copy/pasted below).

There used to be plugin-container.exe but that may have changed with the recent Firefox update.

You should see it when Flash is running, but otherwise, it would be rarer now that other plugins are not enabled.

Also at the moment there are multiple chrome processes evident in Task Manager.

Presumably because you have multiple tabs open in Google Chrome?


Clean Reinstall

We use this name, but it's not about removing your settings, it's about making sure the program files are clean (no inconsistent or alien code files). As described below, this process does not disturb your existing settings. It's not essential to uninstall Firefox, but you can if you like, saying No to any request about removing personal data.

It only takes a few minutes.

(A) Download a fresh installer for Firefox to a convenient location. You can choose between:

Regular version for Windows 7-10 https://www.mozilla.org/firefox/all/ Note: only runs Flash, no other legacy plugins "Windows" version is standard 32-bit version you currently run; if you are thinking of switching to the 64-bit version, see: How to switch from 32-bit to 64-bit Firefox

Extended Support Release for Windows XP-10 https://www.mozilla.org/firefox/organizations/all/ Note: Windows (32-bit) runs legacy plugins that ran in Firefox 51; 64-bit runs Flash and Silverlight; if you are thinking of switching to the 64-bit version, see: How to switch from 32-bit to 64-bit Firefox

(B) Exit out of Firefox (if applicable).

(C) Using Windows Explorer/My Computer, rename the program folder as follows:

64-bit Windows users with 32-bit Firefox: Rename

C:\Program Files (x86)\Mozilla Firefox

to

C:\Program Files (x86)\OldFirefox

Other Windows configurations: Rename

C:\Program Files\Mozilla Firefox

to

C:\Program Files\OldFirefox

(D) Run the installer you downloaded in step (A). It should automatically connect to your existing settings.

Note: Some plugins may exist only in that OldFirefox folder. If something essential is missing, look in these folders:

  • \OldFirefox\Plugins
  • \OldFirefox\browser\plugins

Any improvement?

more options

no improvement :(

more options

If you run a scan with AVG does it find anything objectionable, or only when you run Firefox?

Is there any place in AVG's various controls that Firefox or the firefox.exe process could be listed as approved or unapproved to run, or connect to the internet, or do anything else?

more options

No, nothing shows that would suggest any problem, its just the Firefox display that seems affected. Nothing looks out of place in AVG either, Firefox is listed as are the other browsers :(