Претражи подршку

Избегните преваре подршке. Никада од вас нећемо тражити да зовете или шаљете поруке на број или да делите личне податке. Пријавите сумњиве радње преко „Пријавите злоупотребу” опције.

Learn More

Firefox not reloading a page after redirect

  • 1 одговор
  • 7 има овај проблем
  • 6 прегледа
  • Последњи одговор послао cor-el

more options

I have written a login script to redirect back to the index page once you have logged in, and thus reloading the index page for a logged in user, it just displays the previously loaded index page. The new Firefox 12 update doesn't reload the index page once the login script has redirected it back. This problem occurs again and again throughout my site when the processing script redirects firefox back to a page it has already loaded.

Ive tried turning off caching in php with:

   

and in htaccess with:

   <filesMatch "\.(php)$">
   FileETag None
   <ifModule mod_headers.c>
   Header unset ETag
   Header set Cache-Control "max-age=0, no-cache, no-store, must-revalidate"
   Header set Pragma "no-cache"
   Header set Expires "Wed, 11 Jan 1984 05:00:00 GMT"
   </ifModule>
   </filesMatch>


Can anyone explain why firefox 12.0 is doing this? It doesn't do it in other browsers. How can it be solved as soon as possible? Thanks

I have written a login script to redirect back to the index page once you have logged in, and thus reloading the index page for a logged in user, it just displays the previously loaded index page. The new Firefox 12 update doesn't reload the index page once the login script has redirected it back. This problem occurs again and again throughout my site when the processing script redirects firefox back to a page it has already loaded. Ive tried turning off caching in php with: <?php header( "Last-Modified: " . gmdate( "D, j M Y H:i:s" ) . " GMT" ); header( "Expires: " . gmdate( "D, j M Y H:i:s", time() ) . " GMT" ); header( "Cache-Control: no-store, no-cache, must-revalidate" ); header( "Cache-Control: post-check=0, pre-check=0", FALSE ); header( "Pragma: no-cache" ); ?> and in htaccess with: <filesMatch "\.(php)$"> FileETag None <ifModule mod_headers.c> Header unset ETag Header set Cache-Control "max-age=0, no-cache, no-store, must-revalidate" Header set Pragma "no-cache" Header set Expires "Wed, 11 Jan 1984 05:00:00 GMT" </ifModule> </filesMatch> Can anyone explain why firefox 12.0 is doing this? It doesn't do it in other browsers. How can it be solved as soon as possible? Thanks

Сви одговори (1)

more options

A good place to ask advice about web development is at the MozillaZine "Web Development/Standards Evangelism" forum.

The helpers at that forum are more knowledgeable about web development issues.
You need to register at the MozillaZine forum site in order to post at that forum.