Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

vulnerability message

  • 2 replies
  • 0 have this problem
  • 3 views
  • Paskiausią atsakymą parašė James

more options

Why am I getting this from Kaspersky? The most recent version is 108.0.2. Detect date ? 01/17/2023 Severity ? High Description


Multiple vulnerabilities were found in Mozilla Firefox. Malicious users can exploit these vulnerabilities to bypass security restrictions, execute arbitrary code, spoof user interface.

Below is a complete list of vulnerabilities:

   Security vulnerability in SystemPrincipal can be exploited to bypass security restrictions.
   Security vulnerability in WebWorker can be exploited to bypass security restrictions.
   Code execution vulnerability in GTK drag and drop can be exploited remotely to execute arbitrary code.
   Code execution vulnerability in process allocation can be exploited remotely to execute arbitrary code.
   Code execution vulnerability in Devtools can be exploited remotely to execute arbitrary code.
   Memory safety vulnerability can be exploited to execute arbitrary code.
   Security vulnerability in Notification permissions can be exploited to bypass security restrictions.
   Security vulnerability in format directive can be exploited to bypass security restrictions.
   Security UI vulnerability in cross-origin iframe can be exploited to spoof user interface.

Affected products


Mozilla Firefox earlier than 109.0 Solution


Update to the latest version Download Firefox

Why am I getting this from Kaspersky? The most recent version is 108.0.2. Detect date ? 01/17/2023 Severity ? High Description Multiple vulnerabilities were found in Mozilla Firefox. Malicious users can exploit these vulnerabilities to bypass security restrictions, execute arbitrary code, spoof user interface. Below is a complete list of vulnerabilities: Security vulnerability in SystemPrincipal can be exploited to bypass security restrictions. Security vulnerability in WebWorker can be exploited to bypass security restrictions. Code execution vulnerability in GTK drag and drop can be exploited remotely to execute arbitrary code. Code execution vulnerability in process allocation can be exploited remotely to execute arbitrary code. Code execution vulnerability in Devtools can be exploited remotely to execute arbitrary code. Memory safety vulnerability can be exploited to execute arbitrary code. Security vulnerability in Notification permissions can be exploited to bypass security restrictions. Security vulnerability in format directive can be exploited to bypass security restrictions. Security UI vulnerability in cross-origin iframe can be exploited to spoof user interface. Affected products Mozilla Firefox earlier than 109.0 Solution Update to the latest version Download Firefox

All Replies (2)

more options

To expand on that last reply, Firefox 109.0 was released last Tuesday. Possibly Kaspersky is alerting you to the public information Mozilla provided at that time:

https://www.mozilla.org/en-US/security/advisories/mfsa2023-01/

Is your Firefox able to find the latest update using the Help > About method in this article: Update Firefox to the latest release?

more options

uncleal53 said

Why am I getting this from Kaspersky? The most recent version is 108.0.2. Detect date Affected products Mozilla Firefox earlier than 109.0 Solution Update to the latest version Download Firefox

Yet in your own post it mentions the current version as 109.0 as the most recent as Fx 109.0 was released last week on January 17, 2023


Dropa said

One thing your Browser is out of date and another is that kaspersky isn't well trusted anymore because of it's country of Origin as well.

Though in this case Kaspersky gave proper information that anybody can easily find info on.