Mozilla Support में खोजें

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

One site blank in Linux FF but not in Windows FF

  • 6 प्रत्युत्तर
  • 0 यह समस्या है
  • 1 view
  • के द्वारा अंतिम प्रतियुतर jonzn4SUSE

more options

https:\\archive.org works perfectly in Firefox on Win-10, but on a new Linux Mint install, (with default Firefox as included), this particular website simply displays as a blank white screen. Every other website I try on the Linux install works perfectly; it is only this one website which does not work.

There are no add-ons, no proxies, no security suites, nothing extra. I cleared all cookies and cache. Tried running FF in Protected Mode. Nothing seems to fix it.  There are no error messages displayed - just a blank white screen.

And, to make it worse, I am not particularly computer-literate, (I'm 82 years old...), so you will have to give me simple guidance if I need to get involved with deeper logging etc.

https:\\archive.org works perfectly in Firefox on Win-10, but on a new Linux Mint install, (with default Firefox as included), this particular website simply displays as a blank white screen. Every other website I try on the Linux install works perfectly; it is '''only''' this one website which does not work. There are no add-ons, no proxies, no security suites, nothing extra. I cleared all cookies and cache. Tried running FF in Protected Mode. Nothing seems to fix it. There are no error messages displayed - just a blank white screen. And, to make it worse, I am not particularly computer-literate, (I'm 82 years old...), so you will have to give me simple guidance if I need to get involved with deeper logging etc.

All Replies (6)

more options

For me it looks like a DNS issue. You're probably using Cloudflare.

To test it out:

  1. Click the menu PhotonMenuButton button at the top right of the screen.
  2. Click Settings.
  3. Click Privacy & Security on the left.
  4. Scroll down to the DNS over HTTPS section.
  5. Select Increased Protection and choose NextDNS or https://dns0.eu
  6. Restart the browser

Helpful?

more options

Not sure who or what Cloudflare is, but, no, I am not knowingly using it. My ISP is a little company in eastern Canada, called Purple Cow. The Windows and Linux applications are using exactly the same connections, (and have the same settings in Firefox). I did, however, follow your kind advice, and set the DNS over HTTPS to NextDNS. Did not fix the problem.

But I am most grateful to you for your advice.

Helpful?

more options

Probably you meant // in your original post and not \\ (Firefox always uses forward slashes in web addresses).

What about the Wayback Machine -- will your Firefox load this address:

https://web.archive.org/

Helpful?

more options

You are correct: I meant forward slashes.

And, yes, the Linux Firefox loads web.archive.org/ , but NOT plain archive.org. What does this mean? (The simple one loads in the Windows version, but not under Linux. I can get to the archive.org pages by clicking on a choice in the ribbon at the top of the screen in web.archive.org, but not directly. And I can even go back to a particular BBC recording in "Audio", by using the "History" in Firefox on Linux. (A bit clumsy, but works...)

Incidentally, following the usual first advice: "Reboot", I tried this, but it made no difference. I still get a blank white screen with archive.org,

Update: No idea what happened, but when I went through web.archive.org, then to Audio, then to an actual file, (which left a trace in History), this resulted in the plain archive.org suddenly working normally in Linux. Obviously triggered some internal flag, (or something...?) Tell you what - I will keep this open for a day or two, to make sure it is stable. If everything works properly then, I will close the issue.

Thank you so much for your absolutely invaluable help, (even if, as I suspect, neither of us knows what happened to fix it.)

Helpful?

more options

It's possible that with a visit in the cache, Firefox has an easier time getting to the site than when it is resolving the bare URL or waiting for an HTTP to HTTPS redirect.

Helpful?

more options

You can try to clear all items for a single site. https://support.mozilla.org/en-US/kb/remove-websites-address-bar-suggestions

Site works for me. see screenshot

Try downloading Firefox from Mozilla. Download, unzip, and run firefox-bin from the folder and see if you have the same issue. https://www.mozilla.org/en-US/firefox/all/#product-desktop-release

Helpful?

प्रश्न पूछें

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.