חיפוש בתמיכה

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Move the search trigger at the end of the suggestion list

  • 6 תגובות
  • 0 have this problem
  • 1 view
  • תגובה אחרונה מאת Laurent

more options

The vast majority of the time, when I open a new tab, I want to go to a page I already visited. Unfortunately, I consistently have to press down arrow to get to what I'm looking for.

I already disabled any kind of search suggestion (settings screenshot attached), added the separate search field, but nothing I tried removed the "Search with DuckDuckGo" being the first suggestion. I pressed the down arrow so many times in my life because of this, I'm at a loss.

Am I missing something? Is there any way to get the history suggestions to be before ANY web search.

The vast majority of the time, when I open a new tab, I want to go to a page I already visited. Unfortunately, I consistently have to press down arrow to get to what I'm looking for. I already disabled any kind of search suggestion (settings screenshot attached), added the separate search field, but nothing I tried removed the "Search with DuckDuckGo" being the first suggestion. I pressed the down arrow so many times in my life because of this, I'm at a loss. Am I missing something? Is there any way to get the history suggestions to be before ANY web search.
צילומי מסך מצורפים

כל התגובות (6)

more options

Follow up thought, and it might be Firefox bug, but as a user I really feel like unchecking "Search engines" in the Address Bar Suggestions list should remove the first "Search with DuckDuckGo" suggestion.

Helpful?

more options

The top bar of the drop-down shows what Firefox will do if you were to press Enter or click the Go button at the right end of the bar. It's normal for multi-word input to go to search.

You may have noticed that Firefox will suggest sites in the address bar as you type (before you type a space), but that it only shows top level addresses, and not deep links within a site. There is an experimental feature you could try that enhances the in-URL-bar autofill feature with longer suggestions. It is designed to learn as you go, so you still might need to arrow down a few times to train it. If you're interested, here's how you set it up:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future.

(2) In the search box in the page, type or paste browser.urlbar.autoFill and pause while the list is filtered

Firefox should show 3 matches. Make sure browser.urlbar.autoFill has its default value of true.

(3) Double-click the browser.urlbar.autoFill.adaptiveHistory.enabled preference to switch the value from false to true

Any luck with this feature?

השתנתה ב־ על־ידי jscher2000 - Support Volunteer

Helpful?

more options

I changed the setting, and tried to "train" the thing a good 50 times typing "project volu" and selecting the first github history hit, but nothing seems to change the behavior.

I really believe that it is a bug in Firefox at this point. Disabling search suggestions should disable (or at least de-prioritize) the suggestion to search. Enable the standalone search bar should also probably disable search in the URL bar.

Helpful?

more options

Maybe:

  • about:config => browser.urlbar.showSearchSuggestionsFirst => false

Helpful?

more options

Laurent said

I changed the setting, and tried to "train" the thing a good 50 times typing "project volu" and selecting the first github history hit, but nothing seems to change the behavior.

Hmm, maybe it only works with continuous text (no space).

Helpful?

more options

cor-el said

Maybe:
  • about:config => browser.urlbar.showSearchSuggestionsFirst => false

I tried this, and no change. I basically searched about:config for "suggestion" and disabled anything that remotely sounded like it, and nothing is hiding this 😣

I event tried removing duckduckgo from my list of search (so I have no search engines), and it reverted instantly to google.

Note: I tried Safari on my wife's computer (screenshot attached) and it does basically what I would expect when search is disabled. First hit in the browsing history

Helpful?

פרסום שאלה

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.