Where did you install Firefox from? Help Mozilla uncover 3rd party websites that offer problematic Firefox installation by taking part in our campaign. There will be swag, and you'll be featured in our blog if you manage to report at least 10 valid reports!

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox (or maybe Flash Player) keeps circumventing my computer's audio playback device, and I can't change it back without restarting the computer.

  • 4 respostas
  • 7 have this problem
  • 2 views
  • Last reply by bioactive

more options

I have a USB audio device I only use occasionally (for recording), but normally my system default is Speakers. Firefox will often randomly switch audio devices from "Speakers" to "USB Audio" for no apparent reason, though the rest of my system remains unaffected. If I completely disable the USB audio device, sound from Firefox simply doesn't play.

Once this starts, the only way to fix it is to restart the computer. But it usually happens again a few hours later, usually while using the Flash Player plugin (YouTube, etc.).

It will invariably do this on Soundcloud. I don't know why. I haven't been able to use it in months.

I am running Windows 7 64-bit

I have a USB audio device I only use occasionally (for recording), but normally my system default is Speakers. Firefox will often randomly switch audio devices from "Speakers" to "USB Audio" for no apparent reason, though the rest of my system remains unaffected. If I completely disable the USB audio device, sound from Firefox simply doesn't play. Once this starts, the only way to fix it is to restart the computer. But it usually happens again a few hours later, usually while using the Flash Player plugin (YouTube, etc.). It will invariably do this on Soundcloud. I don't know why. I haven't been able to use it in months. I am running Windows 7 64-bit

All Replies (4)

more options

Hello,

Try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • You can open Firefox 4.0+ in Safe Mode by holding the Shift key when you open the Firefox desktop or Start menu shortcut.
  • Or open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

Once you get the pop-up, just select "'Start in Safe Mode"

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

Thank you.

more options

Safe Mode has no effect. If it starts circumventing my audio set-up, it continues to do so with add-ons disabled.

more options

does this happen in windows safe mode, it may be a audio driver prob

more options

I don't know, I'd have to run it in Safe Mode for several hours to find out. But Firefox is the only application with this problem. Everything else can run all day without trouble.