Where did you install Firefox from? Help Mozilla uncover 3rd party websites that offer problematic Firefox installation by taking part in our campaign. There will be swag, and you'll be featured in our blog if you manage to report at least 10 valid reports!

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

When I try to download a jpg or jpeg file, Firefox converts it to png.

  • 9 respostas
  • 1 has this problem
  • 1 view
  • Last reply by FredMcD

more options

When I try to download a jpg or jpeg file, Firefox converts it to png. Why is this and how can I stop it? Thanks, Mike.

When I try to download a jpg or jpeg file, Firefox converts it to png. Why is this and how can I stop it? Thanks, Mike.

Chosen solution

There was a Silverlight plugin that was out of date. I updated it and the problem went away. I'm not entirely convinced that Silverlight was causing the problem, but maybe it was. Thank you for your help cor-el and FredMcd. Mike.

Ler a resposta no contexto 👍 0

All Replies (9)

more options

That should not happen unless you, or an add-on, is changing it. Or, was it a png in the first place?

Right click on the image and select Save Image As What is displayed as far as the extention?

more options

No, it was not png in the first place, it was jpeg. I tried save image as, but when the dialog comes up it has already changed the extension to png. I also suspected a plug in. The only one that looks like it might be a problem is the picasa plug in. This is my mother's computer. I do not use picasa and I do not know anything about it, but I have tried googling my problem many different ways, both including or not including the word picasa in my search, and apparently I am the only person in the universe who is having this problem. I have noticed that various conversion plug ins exist that are designed to do just the kind of thing that is giving me a problem, but I do not see any such thing in my list of installed add ons, plug ins, etc.

more options

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
key, and then starting Firefox. Is the problem still there?

While still in Safe Mode,

Type about:support in the address bar and press Enter. Under the main banner, press the button; Copy Text To Clipboard.. Then in the reply box at the bottom of this page, do a right click in the box and select Paste. This will show us your system details. No Personal Information Is Collected.

more options

Do all files work properly if you change the file extension to .jpg when you save the file?

Try to rename (or delete) the mimeTypes.rdf file in the Firefox profile folder to reset all file actions.

You can use this button to go to the current Firefox profile folder:

You can inspect the MIME database key with the registry editor (regedit.exe) and do a search for that MIME type (file extension) via Ctrl+F. Be cautious with editing the registry as there is NO UNDO possible: all changes are applied immediately. You can export key(s) in the registry editor before making changes. You can check specific file extension keys (e.g. .jpg) in the registry with the registry editor.


You can check the linked MIME type in the MIME Database registry key.

  • HKEY_CLASSES_ROOT\MIME\Database\Content Type\

cor-el modificouno o

more options

Application Basics

Name: Firefox Version: 43.0.3 Build ID: 20151223140742 Update Channel: release User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:43.0) Gecko/20100101 Firefox/43.0 Multiprocess Windows: 0/1 (default: false) Safe Mode: true

Crash Reports for the Last 3 Days

All Crash Reports



Adapter Description: AMD Radeon HD 8240 Adapter Drivers: aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64 Adapter RAM: 512 Asynchronous Pan/Zoom: none Device ID: 0x9838 DirectWrite Enabled: false (6.3.9600.18123) Driver Date: 8-21-2013 Driver Version: GPU #2 Active: false GPU Accelerated Windows: 0/1 Basic (OMTC) Subsys ID: 368717aa Supports Hardware H264 Decoding: No; Hardware video decoding disabled or blacklisted Vendor ID: 0x1002 windowLayerManagerRemote: true AzureCanvasBackend: skia AzureContentBackend: cairo AzureFallbackCanvasBackend: cairo AzureSkiaAccelerated: 0

Important Modified Preferences

accessibility.typeaheadfind.flashBar: 0 browser.cache.disk.capacity: 358400 browser.cache.disk.filesystem_reported: 1 browser.cache.disk.hashstats_reported: 1 browser.cache.disk.smart_size.first_run: false browser.cache.disk.smart_size.use_old_max: false browser.cache.frecency_experiment: 1 browser.download.importedFromSqlite: true browser.download.useDownloadDir: false browser.places.smartBookmarksVersion: 7 browser.sessionstore.upgradeBackup.latestBuildID: 20151223140742 browser.startup.homepage: https://login.live.com/login.srf?wa=wsignin1.0&rpsnv=12&ct=1425831511&rver=6.4.6456.0&wp=MBI_SSL_SHARED&wreply=https:%2F browser.startup.homepage_override.buildID: 20151223140742 browser.startup.homepage_override.mstone: 43.0.3 dom.apps.reset-permissions: true dom.mozApps.used: true extensions.lastAppVersion: 43.0.3 gfx.crash-guard.d3d11layers.appVersion: 43.0.3 gfx.crash-guard.d3d11layers.deviceID: 0x9838 gfx.crash-guard.d3d11layers.driverVersion: gfx.crash-guard.d3d11layers.feature-d2d: true gfx.crash-guard.d3d11layers.feature-d3d11: true gfx.crash-guard.glcontext.gfx.driver-init.direct3d11-angle: true gfx.crash-guard.glcontext.gfx.driver-init.webgl-angle: true gfx.crash-guard.glcontext.gfx.driver-init.webgl-angle-force-d3d11: false gfx.crash-guard.glcontext.gfx.driver-init.webgl-angle-force-warp: false gfx.crash-guard.glcontext.gfx.driver-init.webgl-angle-try-d3d11: true gfx.crash-guard.status.d3d11layers: 2 gfx.crash-guard.status.d3d9video: 2 gfx.crash-guard.status.glcontext: 2 gfx.direct3d.last_used_feature_level_idx: 0 gfx.driver-init.appVersion: 42.0 gfx.driver-init.deviceID: 0x9838 gfx.driver-init.driverVersion: gfx.driver-init.feature-d2d: true gfx.driver-init.feature-d3d11: true gfx.driver-init.status: 2 media.gmp-eme-adobe.abi: x86-msvc media.gmp-eme-adobe.lastUpdate: 1447270044 media.gmp-eme-adobe.version: 15 media.gmp-gmpopenh264.abi: x86-msvc media.gmp-gmpopenh264.lastUpdate: 1447884932 media.gmp-gmpopenh264.version: 1.5.1 media.gmp-manager.buildID: 20151223140742 media.gmp-manager.lastCheck: 1451328020 media.hardware-video-decoding.failed: false network.auth.allow-subresource-auth: 2 network.cookie.prefsMigrated: true network.predictor.cleaned-up: true places.database.lastMaintenance: 1451142595 places.history.expiration.transient_current_max_pages: 92978 plugin.disable_full_page_plugin_for_types: application/pdf plugin.importedState: true print.printer_EPSON_XP-400_Series.print_bgcolor: false print.printer_EPSON_XP-400_Series.print_bgimages: false print.printer_EPSON_XP-400_Series.print_colorspace: print.printer_EPSON_XP-400_Series.print_command: print.printer_EPSON_XP-400_Series.print_downloadfonts: false print.printer_EPSON_XP-400_Series.print_duplex: 1515870810 print.printer_EPSON_XP-400_Series.print_edge_bottom: 0 print.printer_EPSON_XP-400_Series.print_edge_left: 0 print.printer_EPSON_XP-400_Series.print_edge_right: 0 print.printer_EPSON_XP-400_Series.print_edge_top: 0 print.printer_EPSON_XP-400_Series.print_evenpages: true print.printer_EPSON_XP-400_Series.print_footercenter: print.printer_EPSON_XP-400_Series.print_footerleft: &PT print.printer_EPSON_XP-400_Series.print_footerright: &D print.printer_EPSON_XP-400_Series.print_headercenter: print.printer_EPSON_XP-400_Series.print_headerleft: &T print.printer_EPSON_XP-400_Series.print_headerright: &U print.printer_EPSON_XP-400_Series.print_in_color: true print.printer_EPSON_XP-400_Series.print_margin_bottom: 0.5 print.printer_EPSON_XP-400_Series.print_margin_left: 0.5 print.printer_EPSON_XP-400_Series.print_margin_right: 0.5 print.printer_EPSON_XP-400_Series.print_margin_top: 0.5 print.printer_EPSON_XP-400_Series.print_oddpages: true print.printer_EPSON_XP-400_Series.print_orientation: 0 print.printer_EPSON_XP-400_Series.print_page_delay: 50 print.printer_EPSON_XP-400_Series.print_paper_data: 1 print.printer_EPSON_XP-400_Series.print_paper_height: 11.00 print.printer_EPSON_XP-400_Series.print_paper_name: print.printer_EPSON_XP-400_Series.print_paper_size_type: 0 print.printer_EPSON_XP-400_Series.print_paper_size_unit: 0 print.printer_EPSON_XP-400_Series.print_paper_width: 8.50 print.printer_EPSON_XP-400_Series.print_plex_name: print.printer_EPSON_XP-400_Series.print_resolution: 1515870810 print.printer_EPSON_XP-400_Series.print_resolution_name: print.printer_EPSON_XP-400_Series.print_reversed: false print.printer_EPSON_XP-400_Series.print_scaling: 0.70 print.printer_EPSON_XP-400_Series.print_shrink_to_fit: false print.printer_EPSON_XP-400_Series.print_to_file: false print.printer_EPSON_XP-400_Series.print_unwriteable_margin_bottom: 0 print.printer_EPSON_XP-400_Series.print_unwriteable_margin_left: 0 print.printer_EPSON_XP-400_Series.print_unwriteable_margin_right: 0 print.printer_EPSON_XP-400_Series.print_unwriteable_margin_top: 0 privacy.sanitize.migrateFx3Prefs: true storage.vacuum.last.index: 1 storage.vacuum.last.places.sqlite: 1450196634 ui.osk.debug.keyboardDisplayReason: IKPOS: Rotation sensor not found.

Important Locked Preferences


Incremental GC: true


Activated: true Prevent Accessibility: 0

Library Versions

NSPR Expected minimum version: 4.10.10 Version in use: 4.10.10

NSS Expected minimum version: 3.20.2 Basic ECC Version in use: 3.20.2 Basic ECC

NSSSMIME Expected minimum version: 3.20.2 Basic ECC Version in use: 3.20.2 Basic ECC

NSSSSL Expected minimum version: 3.20.2 Basic ECC Version in use: 3.20.2 Basic ECC

NSSUTIL Expected minimum version: 3.20.2 Version in use: 3.20.2

Experimental Features

more options

I almost forgot to try downloading a jpeg while in safe mode. I just tried it now and it worked with no problems. Mike.

more options

It could be the work of one of your add-ons. Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control>(Mac:<Command>)<Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is detective.

more options

Chosen Solution

There was a Silverlight plugin that was out of date. I updated it and the problem went away. I'm not entirely convinced that Silverlight was causing the problem, but maybe it was. Thank you for your help cor-el and FredMcd. Mike.

more options

That was very good work. Well Done. Please flag your last post as Solved Problem so others will know.

https://www.microsoft.com/getsilverlight/get-started/install/default.aspx Silverlight 5 (5.1.41105.0)

Use this link to check that your plugins are up-to-date. If any are listed as unknown or research, do not worry about them.