Buscar en Ayuda

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

TVHeadend stream not playable

  • 3 respuestas
  • 0 tienen este problema
  • 1 visita
  • Última respuesta de GerardoPcp04

more options

I have been using the TVHeadend server for many years to watch TV channels remotely via a browser. However, for years I have been forced to use blink-based web browsers because it has never been possible for Firefox to be able to watch such TV streams. Moreover, after consulting TVHeadend forums, no Linux user is able to watch such channels with Firefox and they have to use any of the other browsers.

That's why I'm asking you directly. I have all the necessary drivers and codecs on Linux to watch any kind of video and audio container and yet Firefox is unable to display the embedded video through the TVHeadend GUI.

After clicking on the TV icon in TVHeadend, the floating playback window pops up showing "An unknow error occurred" and in console, I can see the following error messages:

The HTTP "Content-Type" of "audio/mp2t" is not supported. The media resource http://192.168.1.11:9981/stream/channel/8ae0334fc3ef1e65c923582bdc53625c. extjs.html failed to load. Failed to load all candidate resources. Media loading paused. extjs.html Unable to play media. There are no decoders for the requested formats: video/MP2T, video/webm; codecs="vp8.0 vorbis", application/x-mpegURL; codecs="avc1.42E01E mp4a.40 .2", application/vnd.apple.mpegURL; codecs="avc1.42E01E mp4a.40.2", video/MP2T; codecs="avc1.42E01E mp4a.40.2", video/x-matroska; codecs="avc1.42E0

I have been using the TVHeadend server for many years to watch TV channels remotely via a browser. However, for years I have been forced to use blink-based web browsers because it has never been possible for Firefox to be able to watch such TV streams. Moreover, after consulting TVHeadend forums, no Linux user is able to watch such channels with Firefox and they have to use any of the other browsers. That's why I'm asking you directly. I have all the necessary drivers and codecs on Linux to watch any kind of video and audio container and yet Firefox is unable to display the embedded video through the TVHeadend GUI. After clicking on the TV icon in TVHeadend, the floating playback window pops up showing "An unknow error occurred" and in console, I can see the following error messages: The HTTP "Content-Type" of "audio/mp2t" is not supported. The media resource http://192.168.1.11:9981/stream/channel/8ae0334fc3ef1e65c923582bdc53625c. extjs.html failed to load. Failed to load all candidate resources. Media loading paused. extjs.html Unable to play media. There are no decoders for the requested formats: video/MP2T, video/webm; codecs="vp8.0 vorbis", application/x-mpegURL; codecs="avc1.42E01E mp4a.40 .2", application/vnd.apple.mpegURL; codecs="avc1.42E01E mp4a.40.2", video/MP2T; codecs="avc1.42E01E mp4a.40.2", video/x-matroska; codecs="avc1.42E0
Capturas de pantalla adjuntas

Todas las respuestas (3)

more options

Hola, Lógicamente el Firefox no encuentra ese codec en el sistema operativo (a diferencia de otros navegadores Firefox no incluye los codecs) Revisa la siguiente consulta si puede ayudarte: https://stackoverflow.com/questions/61541250/chrome-firefox-wont-play-hls-video-mp2t-video-stream-in-html-player Saludos

Modificadas por GerardoPcp04 el

Helpful?

more options

Como había comentado, cualquier otro navegador basado en Blink reproduce ese flujo de datos. No sólo eso, QMPlay2 y VLC (aunque éste no cuenta porque incluye sus propios códecs) pueden reproducir ese flujo de datos en el mismo equipo.

Es más, siguiendo el enlace que me has proporcionado, he verificado que tenía instalado precisamente ésa librería (libavcodec58_144) y he instalado las 56,57 y 59, que no estaban instaladas. Pero sigue Firefox sigue sin reproducir el video.

Helpful?

more options

Hola, Desconozco el funcionamiento del navegador Blink, solo comente como funcionaba el Firefox y que deberías verificar según ese link, continuando con lo yo probaría, aclaro que este foro es atendido por usuarios colaboradores, sería lo siguiente en este orden: (aclaro que este foro es atendido por usuarios colaboradores): 1) Ultima versión de Firefox 124. 2) Ultima versión de Firefox 124 en modo seguro y creado un perfil nuevo. 3) En otra distribución de Linux Si continua el problema tendrías que abrir un caso en el foro de los desarrolladores: https://bugzilla.mozilla.org/enter_bug.cgi?format=guided#h=dupes|Firefox| Saludos

Helpful?

Haz una pregunta

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.