Kërkoni te Asistenca

Shmangni karremëzime gjoja asistence. S’do t’ju kërkojmë kurrë të bëni një thirrje apo të dërgoni tekst te një numër telefoni, apo të na jepni të dhëna personale. Ju lutemi, raportoni veprimtari të dyshimtë duke përdorur mundësinë “Raportoni Abuzim”.

Learn More

thunderbird 68 use of json policy

  • 3 përgjigje
  • 1 e ka hasur këtë problem
  • 1 parje
  • Përgjigjja më e re nga p.v.malkov

more options

json policy was added to TB68 https://www.thunderbird.net/en-US/thunderbird/68.0/releasenotes/

For company CA installation I have firefox policy: /usr/share/firefox-esr/distribution/policies.json

       {
         "policies": {
           "Certificates": {
             "Install": [ "/etc/ca.pem" ]
           }
         }
       }

It works

What is the path for TB policy and filename? mirrored structure did not help /usr/share/thunderbird/distribution/policies.json TB still warnes about certificate

It worked with trick to use system certs, ln -s /usr/lib/x86_64-linux-gnu/pkcs11/p11-kit-trust.so /usr/lib/thunderbird/libnssckbi.so with /usr/local/share/ca-certificates && update-ca-certificates and lockPref("security.enterprise_roots.enabled", true);

but better to use new solution

UPD: I checked source. And it is correct, it uses distribution/policies.json But it does not apply niether

       {
         "policies": {
           "Certificates": {
             "Install": [ "/etc/ca.pem" ]
           }
         }
       }

nor

       {
         "policies": {
           "Certificates": {
             "ImportEnterpriseRoots": true
           }
         }
       }
json policy was added to TB68 https://www.thunderbird.net/en-US/thunderbird/68.0/releasenotes/ For company CA installation I have firefox policy: /usr/share/firefox-esr/distribution/policies.json { "policies": { "Certificates": { "Install": [ "/etc/ca.pem" ] } } } It works What is the path for TB policy and filename? mirrored structure did not help /usr/share/thunderbird/distribution/policies.json TB still warnes about certificate It worked with trick to use system certs, ln -s /usr/lib/x86_64-linux-gnu/pkcs11/p11-kit-trust.so /usr/lib/thunderbird/libnssckbi.so with /usr/local/share/ca-certificates && update-ca-certificates and lockPref("security.enterprise_roots.enabled", true); but better to use new solution UPD: I checked source. And it is correct, it uses distribution/policies.json But it does not apply niether { "policies": { "Certificates": { "Install": [ "/etc/ca.pem" ] } } } nor { "policies": { "Certificates": { "ImportEnterpriseRoots": true } } }

Ndryshuar nga p.v.malkov

Zgjidhje e zgjedhur

after FF installation link is created

       /usr/lib/firefox-esr/distribution --> ../../share/firefox-esr/distribution

check code why TB does not do it I created link manually and bingo, it started working

       /usr/lib/thunderbird/distribution --> ../../share/thunderbird/distribution
Lexojeni këtë përgjigje brenda kontekstit 👍 0

Krejt Përgjigjet (3)

more options

Can you install the certificate using the user interface. I am seeing folks with certificates that are simple not suitable either because they are not issues by certifying authorities (self signed in some cases) or are invalid because the provider is not recognized in the CA chain of trust.

more options

Manuall installation of cert works fine as well as a mail recieving after. The same action

       with_items:
       - /usr/share/firefox-esr/distribution/policies.json
       - /usr/share/thunderbird/distribution/policies.json

before installing FF and TB, but different result.

Ndryshuar nga p.v.malkov

more options

Zgjidhja e Zgjedhur

after FF installation link is created

       /usr/lib/firefox-esr/distribution --> ../../share/firefox-esr/distribution

check code why TB does not do it I created link manually and bingo, it started working

       /usr/lib/thunderbird/distribution --> ../../share/thunderbird/distribution