Avatar for Username

Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

Firefox 126.0 on Sonoma 14.5 not saving passwords

  • 6 ответов
  • 0 имеют эту проблему
  • 1 просмотр
  • Последний ответ от momiller77

more options

After up grading to a Mac Studio running Os 14.5, I downloaded the latest Firefox 126.0. I have three other computers with Firefox. The oldest a Mac Pro running 10.13.6 Hi Sierra that works flawlessly. I tried sync and bookmarks came over to the Mac Studio but not any passwords. I tried importing via a .csv file and got the message: Import complete New passwords added: 0 Existing entries updated: 0 Duplicate entries found: 0 Errors 190 (not imported)

Firefox will NOT even save manually entered passwords. I suspect some problem with Sonoma's paranoid security but I cannot find a solution. Any suggestions?

After up grading to a Mac Studio running Os 14.5, I downloaded the latest Firefox 126.0. I have three other computers with Firefox. The oldest a Mac Pro running 10.13.6 Hi Sierra that works flawlessly. I tried sync and bookmarks came over to the Mac Studio but not any passwords. I tried importing via a .csv file and got the message: Import complete New passwords added: 0 Existing entries updated: 0 Duplicate entries found: 0 Errors 190 (not imported) Firefox will NOT even save manually entered passwords. I suspect some problem with Sonoma's paranoid security but I cannot find a solution. Any suggestions?
Приложенные скриншоты

Выбранное решение

Thanks Cor-el ! I trashed logins.json and key4.db I quit Firefox and restarted I signed in to Mozilla Passwords ARE THERE !!! It (what actually?) worked ! Thanks for putting up with this dunce ! You made my life so much easier ! I can now use my new Mac Studio ! Thanks !

Прочитайте этот ответ в контексте 👍 0

Все ответы (6)

more options

It is possible that the CSV file doesn't have the correct header line that specifies the column names. Make sure you have at least the "url" and "username" and "password" columns as those are mandatory.

If there are problems with importing the CSV file, create a new login via the plus icon in the Password Manager (about:logins) and export the logins to a CSV file to get an example of the format of the CSV file.

Изменено cor-el

Полезно?

more options

Thanks cor-el I will try a new login however my .cvs file has worked in the past on other machines running older OS versions. Plus that did not address the problem of Firefox on Sonoma not even saving manually entered I still think that it is a problem with new security procedures on Sonoma. I have been trying to figure this out but so far it is beyond my ancient and crude intellect. Thanks for the suggestions! Mo Miller.

Полезно?

more options

If you can't create a new login manually then try to rename/remove the current logins.json and key4.db and let Firefox create new files.

You can temporarily set signon.debug => true in about:config.

You can open the about:logins page and start the import and check the Browser Console for login related messages. You can clear the messages in the console beforehand and only enable Errors and Warnings, hidden items may have an item count appended. Do not forget to reset signon.debug to false after you are done testing.

Полезно?

more options

Thanks cor-el but I believe there is a fundamental difference in my Firefox running on Sonoma. I am reluctant to change things in about:config and further mess up things.

1. I believe my .csv file is good 2. I cannot save ANY passwords in Firefox either manually nor by import 3. I cannot set a Primary Password in Firefox

In a search in about:config for "passwords" I get :

pref.privacy.disable_button.view_passwords false pref.privacy.disable_button.view_passwords_exceptions false services.sync.engine.passwords true services.sync.engine.passwords.validation.interval 86400 services.sync.engine.passwords.validation.maxRecords 1000 services.sync.engine.passwords.validation.percentageChance 10 signon.management.page.vulnerable-passwords.enabled true

In a search for "signon" I get a lot. Here are the FALSE settings

signon.autofillForms.http false signon.autologin.proxy false signon.management.page.os-auth.enabled false sidnon.relatedRealms.enabled false

As usual, I have no idea what the above means of if it is relevant! Sorry to be so dense! Mo Miller

Полезно?

more options

Best is the set signon.debug temporarily to true in about:config. and check the Browser Console login related messages, leave all other prefs at their current (default) value.

You may have to rename/remove logins.json and key4.db and it sound that there is a problem with key4.db since you aren't able to set the Primary Password.

You can use the button on the "Help -> More Troubleshooting Information" (about:support) to go to the current Firefox profile folder or use the about:profiles page (Root directory).

Полезно?

more options

Выбранное решение

Thanks Cor-el ! I trashed logins.json and key4.db I quit Firefox and restarted I signed in to Mozilla Passwords ARE THERE !!! It (what actually?) worked ! Thanks for putting up with this dunce ! You made my life so much easier ! I can now use my new Mac Studio ! Thanks !

Полезно?

Задать вопрос

Для ответа на сообщения вы должны войти в свою учётную запись. Пожалуйста, задайте новый вопрос, если у вас ещё нет учётной записи.