Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Help repost

  • 1 reply
  • 1 has this problem
  • 4 views
  • Paskiausią atsakymą parašė Happy112

more options

UPDATE: I tried reinstalling Windows to see if there was like a corrupt file. I had to reinstall all my drivers and this time I thought I'd go with Firefox version 45.0.1 as a clean install. Still however the problem persists. As soon I log in to my Facebook account and scroll to a video, the video thumbnail shows but just doesn't play. I again tried the flash video downloader add-on to force flash to play but still no response. Once again I've always been an avid Firefox user and DO NOT want to switch to another browser just to play videos on Facebook,

UPDATE: I tried reinstalling Windows to see if there was like a corrupt file. I had to reinstall all my drivers and this time I thought I'd go with Firefox version 45.0.1 as a clean install. Still however the problem persists. As soon I log in to my Facebook account and scroll to a video, the video thumbnail shows but just doesn't play. I again tried the flash video downloader add-on to force flash to play but still no response. Once again I've always been an avid Firefox user and DO NOT want to switch to another browser just to play videos on Facebook,

All Replies (1)

more options

Please, continue this in your original post :

https://support.mozilla.org/en-US/questions/1160867

(I will flag this one)