Mozilla サポートの検索

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

このスレッドはアーカイブに保管されました。 必要であれば新たに質問してください。

How do I install quicktime plugin on firefox 4 on OS X Snow Leopard?

  • 15 件の返信
  • 238 人がこの問題に困っています
  • 1 回表示
  • 最後の返信者: smoller

more options

Firefox 4 does not have the quicktime plugin and I can't find a way to install it.

I noticed it when i browsed to this site: http://www.panic.com/coda/developer/videos/ui-essentials/

I have OS X Snow Leopard, Quicktime X and firefox 4 beta 7.

Firefox 4 does not have the quicktime plugin and I can't find a way to install it. I noticed it when i browsed to this site: http://www.panic.com/coda/developer/videos/ui-essentials/ I have OS X Snow Leopard, Quicktime X and firefox 4 beta 7.

すべての返信 (18)

more options

OS X handles internet plug-ins system-wide, so if you have the Quicktime (which installs along with OSX by default) it should already be there.

Go to your hard drive, and open Library > Internet Plug-Ins > and look for "QuickTime Plugin.plugin".

Alternately, in Terminal code: Type: cd //Library/"Internet Plug-Ins"/ then type: "ls" and look for "QuickTime Plugin.plugin"

If the Quicktime Plugin isn't there then it means you need to re-install quicktime, either by downloading it off apple's web site, or by installing it from the OS X 10.6 disk.

more options

Yeah, I found that file, but it doesn't show up under plugins in firefox. I tried installing it in firefox by selecting "Install Add-on From File..." and it did not work.

I might add that it works in safari (duh)...

Hmm, any thoughts? Maybe I should try installing Quicktime 7?

more options

I don't know, maybe a re-install of firefox is required.

more options

Nope, didn't help =/

more options

This is a bug in Beta7. It is marked as blocking the release of Beta 8.

more options

Some newly discovered info:
This bug is specific to 64-bit versions of Firefox. Starting in Firefox 4 Beta 7, Firefox is offered as a i386/x86_64 universal binary to Mac users, and defaults to 64-bit mode on OS X 10.6.

If you run Firefox in 32-bit mode, you should see the QT plugin again. Like I said earlier, the bug is marked as blocking the release of Beta 8, which means that if everything else is finished for Beta 8, it won't be released until this bug is fixed.

more options

Alright :) thanks for the answer!

more options

Hi there, Did you mean if i switch firefox4 to run in 32-bit mode, the Quicktime will be working?

more options

Yup. :-) Just remember to set it back when Beta 8 comes out (tentatively scheduled for November 30th). It's easy to forget about a setting like that.

more options

looks like the bug fix has been deferred to Beta 9.

more options

Just installed the Beta 8 and the plugin vanished again! ( it wasn't working in beta 7 at first but suddenly one day it showed up.)

How do i run Firefox in 32bit?

more options

Here's how to run firefox in 32bit until this bug is fixed:

1. Quit firefox

2. Go to the applications folder and find Firefox

3. Right click (or ctrl-click) on the Firefox icon and click "Get Info"

4. Tick the "Open in 32-bit mode" and close the Info window

5. Start Firefox again

6. Enjoy a working QuickTime!

この投稿は Zzzzeb により に変更されました

more options

Beta 9 was released last week, and it contains a fix for this issue. If you haven't already upgraded, make sure you do and you won't have this problem.

Also, if you set Firefox to open in 32-bit mode, remember to set it back.

To update Firefox 4 on Mac, go to Firefox > About Firefox. In the resulting window, click Check for Updates.

more options

I just installed FF4 yesterday and the quicktime plugin issue is still lingering. I have checked the updates section, as posted by Chris_llias and it's showing I am up to date.

more options

This is something I would expect from a dinosaur like Microsoft.

Yes, ticking "Open in 32-bit mode" in the app's get-info window works, but this isn't the default after installing. So, by default Firefox 4 does not support QuickTime.

Version 4 was really launched with this issue?

Not impressed.

more options

Similar situation here; I am using the released version of Firefox 4 on Snow Leopard and, although my QuickTime plugin is installed (under QuickTime X with Snow Leopard), it cannot play embedded sound in numerous Websites. (Sometimes it complains that "Additional software is required by QuickTime", occasionally the sound actually plays, and sometimes the plugin crashes - once taking Firefox with it.)

"Solution:" Switch to 32-bit mode.

Clearly there is a basic incompatibility between the plugin QuickTime 7.6.6 (Apple software update tells me it is up to date and will not install any newer versions) and 64-bit configured FF4.

more options

Similar issue persisting here - I get sound but no video. Firefox 4.0, QuickTime 7.6.6, Mac OS 10.6.7. Switching to 32-bit mode works, but that's definitely not an ideal fix.

more options

Same problem here - FF4.0, Quicktime 7.6.6, Mac OS X 10.6.6 and I keep getting the "Additional software is required by QuickTime" message.