Cari Bantuan

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Change default view

more options

Currently, Firefox opens OBJ files as text. I want to send them to the Microsoft 3D Viewer which is the default application in Windows for these kinds of files. All I can do right now is right click on the file, save the file, then open with the 3D Viewer. I have gone to settings/General then down to applications and I can't add any files there. (Why not?) It doesn't matter if I choose to save or open files, the OBJ file still displays as text in Firefox. How do I get Firefox to send instead of display these files as text?

Currently, Firefox opens OBJ files as text. I want to send them to the Microsoft 3D Viewer which is the default application in Windows for these kinds of files. All I can do right now is right click on the file, save the file, then open with the 3D Viewer. I have gone to settings/General then down to applications and I can't add any files there. (Why not?) It doesn't matter if I choose to save or open files, the OBJ file still displays as text in Firefox. How do I get Firefox to send instead of display these files as text?

Solusi terpilih

If both browsers think it's a text file, that's probably what the server is telling them. I don't suppose it's a site that would be willing to update the Content-Type sent with the files?

Baca jawaban ini dalam konteks 👍 0

Semua Balasan (7)

more options

Hmm, I wonder how Firefox figured out that it's a text file?

Firefox normally follows the guidance of the server in the Content-Type header that is sent with the file. If a server is well configured, the Content-Type will be sensible, but some servers have a basic set of content types and then they fall back to text for everything else, which is sort of useless.

Option #1

You can try training Firefox to open the OBJ files using the Downloads list. Click the Downloads button on the toolbar, right-click the OBJ file you saved, then -- if it's available -- click Always Open Similar Files. This should trigger Firefox to add a new entry on the Settings page for whatever the server said the Content-Type was.

Option #2

If the server is sending a nonsense Content-Type, I have my add-on that can help. What it does it override the Content-Type based on the file extension. The .OBJ extension is not set up at install time, but you can add it using the method described on my page here:

https://www.jeffersonscher.com/ext/content-type-fixer.html

It's the "Roll Your Own Content Type Overrides" section.

The add-on can be installed from:

https://addons.mozilla.org/firefox/addon/content-type-fixer/

Membantu?

more options

This is a more complex solution than I am willing to do, but thank you very much. Where are the Firefox people? Why doesn't Firefox allow you to edit the disposition of files in options?

Membantu?

more options

Did you already do Option #1?

Membantu?

more options

Yes, I tried that and it’s amazing nothing works. However, it does exactly the same thing in Bing. It’s a conspiracy. The only thing I’ve found is that I can right click on the file, use the “save as” selection, then open the file outside of Firefox.

Membantu?

more options

Solusi Terpilih

If both browsers think it's a text file, that's probably what the server is telling them. I don't suppose it's a site that would be willing to update the Content-Type sent with the files?

Membantu?

more options

Well, it’s my site, so I am willing to change it. :) I should have thought of this! Thanks.

Membantu?

more options

Okay, there's either a central config file or .htaccess where you typically define the MIME-types per extension.

Membantu?

Ajukan pertanyaan

Anda harus masuk ke akun Anda untuk membalas kiriman ini. Sila mulai pertanyaan baru, jika Anda belum memiliki akun.