Mozilla Support में खोजें

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

URL autocomplete - I want to start over.

  • 12 प्रत्युत्तर
  • 0 यह समस्या है
  • 1 view
  • के द्वारा अंतिम प्रतियुतर jscher2000 - Support Volunteer

more options

I don’t understand what Firefox is doing. For example, I used to start typing the first few letters of “weather.com”, which I visit pretty much daily, and it would auto fill “weather.com”. Now it auto fills every time with http://www.weatherbase.com/. I don’t know where that came from. Similarly, I used to type the first few letters of “duckduckgo.com” and it would bring up “duckduckgo.com”. Now it brings up a magnifying glass below the url with “Search with duckduckgo”. I am thinking it might be best if I can start over, i.e. clear out any information it’s saved about where it thinks I want to go, and start remembering the sites I am entering now.

I don’t understand what Firefox is doing. For example, I used to start typing the first few letters of “weather.com”, which I visit pretty much daily, and it would auto fill “weather.com”. Now it auto fills every time with http://www.weatherbase.com/. I don’t know where that came from. Similarly, I used to type the first few letters of “duckduckgo.com” and it would bring up “duckduckgo.com”. Now it brings up a magnifying glass below the url with “Search with duckduckgo”. I am thinking it might be best if I can start over, i.e. clear out any information it’s saved about where it thinks I want to go, and start remembering the sites I am entering now.

All Replies (12)

more options

Here my suggestion:

(1) Weather vs. Weatherbase

Try telling Firefox to "forget" about Weatherbase if you never use that site. Here's how:

  • Call up the Library window using Ctrl+Shift+H. Firefox should show your history from today.
  • In the tiny search box at the upper right, type weatherbase to see all history entries for this site.
  • If there are any results, right-click one and choose Forget About This Site to do a deep flush of data for that site.
  • If there were no history results, click All Bookmarks in the left column, then search in Bookmarks.

Any improvement?

(2) DuckDuckGo

It's normal for Firefox to recognize the beginning of a search engine and suggest it in the drop-down below the address bar. This should not interefere with the autofill feature (the one that suggests site addresses in the address bar) or seeing suggestions from your history in the drop-down. However, it's easy to remove if you don't ALSO want to see a search engine suggestion.

Untick the Search engines box in the Address Bar settings, as described in this article:

https://support.mozilla.org/en-US/kb/address-bar-autocomplete-firefox#w_how-can-i-control-what-results-the-address-bar-shows-me

Success?

Helpful?

more options

1) History page is blank. 2) It got rid of “Search with duckduckgo" but does not autocomplete with “duckduckgo.com”.

These were just examples. Solving this on a url by url basis could take forever.

I want to clear out all URLs it remembers and start remembering new ones.

Helpful?

more options

You can rename/remove places.sqlite in the Firefox profile folder to reset all history data. Firefox will/should rebuild the bookmarks that are also stored in this file from a recent backup in the bookmarkbackups folder.

You can use the button on the "Help -> More Troubleshooting Information" (about:support) to go to the current Firefox profile folder or use the about:profiles page (Root directory).

Helpful?

more options

Firefox is not remembering the URLs I am typing recently. Will your solution not only clear out the old stuff but turn its URL memory back on?

Helpful?

more options

Possibly, I don't know what issues you currently have.

You can check for problems with the places.sqlite and favicons.sqlite files in the Firefox profile folder.

  • use the "Places Database" -> "Verify Integrity" button on the "Help -> More Troubleshooting Information" (about:support)

If errors are reported with "Verify Integrity", close and restart Firefox or reboot and retry.

Helpful?

more options

> Task: checkIntegrity + The places.sqlite database is sane + The favicons.sqlite database is sane > Task: checkCoherence + The database is coherent > Task: expire + Database cleaned up > Task: vacuum + Initial database size is 51200KiB + The database has been vacuumed + Final database size is 5120KiB > Task: stats + Places.sqlite size is 5120KiB + Favicons.sqlite size is 4896KiB

Helpful?

more options

Does anyone know how to fix this issue?

WAYNEOO द्वारा सम्पादित

Helpful?

more options

WAYNEOO said

Firefox is not remembering the URLs I am typing recently.

It's worth checking your History settings on the Settings page.

Settings > Privacy & Security > History

The "Firefox will" selector typically is set to "Remember history". If yours is set to "Never remember history" you'll need to switch that back.

It's also an option to "Use custom settings for history". Please review the checkboxes:

[_] Always use private browsing mode [NOT CHECKED] [x] Remember browsing and download history [CHECKED] [?] Remember search and form history [NOT CRITICAL FOR THIS PROBLEM] [?] Clear history when Firefox closes [IF THIS IS CHECKED, CLICK SETTINGS AND MAKE SURE BROWSING HISTORY IS NOT BEING CLEARED]

Helpful?

more options

I thought that might be the problem. I set it to "Never remember history" because I read that Firefox is then less vulnerable to malware. True?

Helpful?

more options

WAYNEOO said

I thought that might be the problem. I set it to "Never remember history" because I read that Firefox is then less vulnerable to malware. True?

I don't think that is true. The main differences between using regular windows and private windows are:

  • "Standard" Tracking Protection blocks more content in private windows than regular windows. To equalize them, use "Strict" Tracking Protection. The selector is at Settings > Privacy & Security.
  • Files saved in the web content cache, and cookies set by websites in previous sessions, are not used in private windows. To equalize them, you can set Firefox to clear cookies when it closes (and Firefox also clears the web content cache with that setting). There's a checkbox for that at Settings > Privacy & Security > Cookies and Site Data.
  • Add-ons need explicit permission to run in private windows. If there is an add-on you don't trust, you can remove it rather than hiding from it by using private windows.

Helpful?

more options

This worked, but now when I start a new FireFox session and go to gmail, gmail logs me in automatically. To me, this is a security risk.

Helpful?

more options

WAYNEOO said

This worked, but now when I start a new FireFox session and go to gmail, gmail logs me in automatically. To me, this is a security risk.

If you didn't sign out of your Google session, it is still alive and can be accessed using the cookie(s) Google set in Firefox the last time you signed in. So, two options:

(1) Sign out of Google when you are done with it.

This closes your session and prevents anyone from accessing your Google data, even if they have access to your Firefox and the cookies Google set in Firefox.

(2) Set Firefox to clear your Google cookies (or all of your cookies) when you close the browser.

There is a Cookies and Site Data on the Settings page (further up from History) where you can either check a box to flush all cookies or use the Manage Permissions button to set "Allow for Session" for Google cookies.

Your Google session is still alive after you close Firefox, but the odds that someone could find the necessary cookies are very low in this scenario.

Helpful?

प्रश्न पूछें

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.