Preguntas más frecuentes - Modernización de la tecnología de complementos en Firefox

¿Qué es una extensión reemplazada?

Aquellas extensiones creadas en entornos que no son compatibles con la versión 57 de Firefox (como SDK o XUL).

¿Cómo puedo saber si tengo instalada alguna extensión reemplazada?

Para ver si tienes instalada alguna extensión incompatible, ve al Administrador de complementos (Menú > Complementos o escribe “about:addons” en una nueva pestaña). Si tienes una extensión reemplazada, te aparecerá una nota como esta en la parte superior de la pantalla:

Legacy extension warning

Para ver una lista de todas las extensiones reemplazadas que tienes instaladas, haz clic en “Mostrar extensiones reemplazadas”. Para buscar una alternativa recomendada, haz clic en la opción “Buscar alternativas” que se encuentra junto a cada extensión reemplazada. Podrás descubrir más sobre esta función en nuestro blog.

Si me aparece la etiqueta “reemplazada”, ¿significa que mi extensión dejará de funcionar si actualizo a la versión 57+?

Sí, todos los complementos que tengan la etiqueta "reemplazado" no funcionarán si actualizas Firefox. No obstante, la mayoría de las extensiones más populares de Firefox son compatibles con la versión 57+. En algunos casos, los desarrolladores están trabajando para actualizar sus extensiones y que sean compatibles con las versiones actuales de Firefox. En estos últimos casos, la extensión se actualizará automáticamente cuando la nueva versión esté disponible.

Si me aparece la etiqueta "reemplazada", ¿significa que mi extensión ya no funciona?

Sí, las extensiones con esa etiqueta no funcionan en la versión 57. En algunos casos, los desarrolladores tendrán que seguir trabajando para hacerlas compatibles antes del lanzamiento oficial el 14 de noviembre de 2017. En estos últimos casos, la extensión se actualizará automáticamente cuando la nueva versión esté disponible.

¿Me podéis recomendar alternativas para mis extensiones?

¡Sí! Puedes echarle un vistazo a nuestra colección de destacados, que incluye las extensiones más populares. También puedes buscar extensiones compatibles en addons.mozilla.org (AMO).

Además, también puedes usar la función de búsqueda para encontrar la extensión que reemplaza a la tuya y descubrir las más recomendadas.

¡Sí! Ve al Administrador de complementos (Menú > Complementos o escribe about:addons en una nueva pestaña) y selecciona Extensiones reemplazadas. Haz clic en la opción “Buscar alternativas” que se encuentra junto a cada extensión reemplazada y te aparecerán las opciones recomendadas. Puedes descubrir más sobre esta función en nuestro blog.

Te recomendamos que busques extensiones compatibles en addons.mozilla.org (AMO) o que le eches un viestazo a nuestra colección de extensiones destacadas.

Además, también puedes usar la función de búsqueda para encontrar la extensión que reemplaza a la tuya y descubrir las más recomendadas.

No hay ninguna alternativa a mis extensiones reemplazadas. ¿Qué puedo hacer?

Si no encuentras ninguna alternativa adecuada, dirígete a nuestro foro y pide sugerencias a nuestra comunidad.

¿Cómo encuentro extensiones que sean compatibles con la versión 57 y posteriores de Firefox?

Puedes buscar extensiones compatibles en addons.mozilla.org. Nuestra colección de extensiones destacadas también incluye extensiones alucinantes que serán compatibles con la versión 57 y posteriores de Firefox.

¿Cuándo se dejarán de funcionar las extensiones reemplazadas en Firefox ESR?

La versión 52 de Firefox ESR es la última versión que admite estas extensiones. ESR 52 dejará de actualizarse el 4 de septiembre de 2018.

¿Dejarán de funcionar mis temas a partir de Firefox 57?

Si estás utilizando un tema destacado, no deberías tener ningún problema. Si estás utilizando un tema completo, se desactivará a partir de la versión 57 y no volverá a funcionar. Si estás usando un tema completo oscuro, puede que una buena alternativa sea la opción Tema oscuro del Administrador de complementos. Ve a la pestaña Temas en la página about:addons y pruébalos.

¿Qué le pasará a mi tema completo?

Los temas completos no son compatibles con Firefox 57+ y se deshabilitarán. Si utilizas un tema completo oscuro, puede que la opción Tema oscuro del Administrador de complementos te interese. Ve a la pestaña Temas en about:addons y échale un ojo. Estamos mejorando los temas y podrás verlo en los próximos meses. Así que en el futuro, busca temas que incluyan más funcionalidad.

¿Qué pasó con mi complemento relacionado con Flash?

A partir del lanzamiento de Firefox 55, Adobe Flash no se ejecuta por defecto, ya que Click-to-run Flash viene ya incorporado en el navegador. Siempre puedes elegir cómo quieres que actúe en ciertas páginas o en todas.

Algunas de las extensiones más populares de Flash ya ofrecían esta función incluso antes de que pasara a formar parte del navegador. Dado que esas exensiones se han quedado obsoletas, los desarrolladores no las admitirán y, por tanto, dejarán de funcionar.

En algunos casos, contamos con APIs de WebExtension que incluyen funciones extras para Flash (como, por ejemplo, Flash LSO deletion) y podemos confirmar que lanzaremos más funcionalidades de Flash en un futuro.

¿Te resultó útil este artículo? Espera por favor...

Esta gente maravillosa ayudó a escribir este artículo: Ángela Velo. Tú también puedes ayudar, descubre cómo hacerlo.