Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

plasmoo has taken over my search engine through firefox

  • 19 replies
  • 419 have this problem
  • Last reply by saron123

more options search engine has taken over my firefox and defaults to it every time I open a window.

How can I remove this plasmoo permanetly search engine has taken over my firefox and defaults to it every time I open a window. How can I remove this plasmoo permanetly

All Replies (19)

more options

Please do the following:

  • In the location bar, type about:config and hit Enter.
  • In the filter at the top, type: keyword.URL
  • Double click it and remove whatever's in there and replace it with
  • Go to File | Exit
  • Restart Firefox, go to the site you want to set as your homepage.
  • Go to Tools | Options | General.
  • Make sure it says "Show My Homepage" in the first dropdown menu.
  • Click the button called "Use Current Pages" to set the homepage to the one you have on the screen.

The URL to add in "keyword.URL" becomes a link in this post, so right click it and choose "Copy Link Location" to copy it to the Windows clipboard. Then hit CTRL+V to paste it. Saves you having to type the whole thing.

more options

Hello thankyou for your help, seems u have encountered this problem before.

For me I followed your instructions and typed in about:config (which warns me I might loose my warranty)...

Then I got a whole list of things e.g;MS P明朝;MS Pゴシック ect....

Then I typed in keyword.URL . and the whole list dissapered

I double click and nothing apperas

Then I remove the words and the list re-appears.

and still got the problem

more options

Click OK to the warranty warning.

See screenshot for how it appears when you go to about:config

When you type in keyword.URL it only displays that setting as can be seen in the bottom half of the image.

In my particular case, it already has google as the search engine, but you'll probably see "plasmoo" there. That's what you have to remove as per instructions above.

Modified by Xircal

more options

hey sorry once i finshed the instructions it is fine

more options

You're welcome.

Could you please click the "Solved it" button to take your post out of the loop?


more options

Hi, I've been through the instructions about half a dozen times now, just to be sure I'm dong it right, but till every time I restart I get plasmoo coming up. I've even just done it back to back cold, still nothing but plasmoo.

I've noticed that in my search bar on the top right, there is now a plasmoo search, which I remove, and bottom right there is a plasmoo icon just above the clock. I've no idea where this is turned on, or off or removed .

On one of my run throughs trying to remove I've noticed this: "CommunityToolbar.SearchFromAddressBarSavedUrl; in the about:config" (quotation marks my own) in the list of stuff. Is this why it's dug a little deeper?

I'm pretty careful about tool bars and search assistant guff, so I've no idea where this came from. Their site makes many claims about privacy and user rights, but I feel pretty violated. Interestingly it also says this: "Easy uninstall – you can easily uninstall the application at any time by using standard uninstall processes as may be available as part of your operating system, your internet browser or similar software uninstall options (for example: add/remove programs in Windows, Add-on removal in Firefox, etc.). "

So Ill give that a go, but don't hold out much hope. Thanks for your help, and other advice is very much appreciated.

more options

@ blank70, go to that CommunityToolbar...etc in about:config and double click it. This will reset it to default which will be deleted when you exit and then restart Firefox.

Could you also please go to Tools | Add-ons | Extensions and see if you can see any references to it there too. If you find any, click the "Remove" button.

more options

Thanks for getting back to me so quickly. I've done all that, now all seems as it should be. But... Out of curiosity I went back to about:config, scrolled down, and there are still alot of plasmoo mentions, I'll list them all here:;;chrome://browser-region/locale/;Google;|;UNINSTALLED

I'm a little nervy of having all that there, does this mean that at some level they are still 'into me' ? If I were to delete that stuff, would it just revert to defaults? Thanks again

more options

found these two too:;Plasmoo;{searchTerms}

Modified by blanko_70

more options

Right click the first one, choose Modify and then type: Google

For the second one, Modify, delete the plasmoo and add this one:

more options

Apologies if I'm being dense... Ok, done that for those last two, but I still have these others....;;chrome://browser-region/locale/;Google;|;UNINSTALLED

Also, should I be worried, as to access here and other stuff I've had to enter my password(s)? Would something like this keylog? It feels pretty intrusive and hardly generates a feeling of trust.

Again, thanks for your help.

more options

Ok I also had this problem due to house mate installing some stupid file converter..

I tried all of the above and whilst it seemed to work the next time i restarted my pc the dreaded plasmoo was back...

So what i did was this.. I redownloaded the latest version of firefox.. Unstalled the file convertor and firerfox.. then reinstalled firefox.. Uninstalled IE then redownloaded and reinstalled it.... Rebooted my pc and no plasmoo anywhere!!

sometimes simple ways are easier...

Modified by Mumsy

more options

Right click any entry with the name plasmoo in about:config and choose Reset from the menu. When you exit and restart Firefox, those will be deleted.

As regards keyloggers, a good malware scanner will detect those. Download Malwarebytes from if you haven't got it already.

What's your operating system blanko_70?

more options

My operating system? (blushes) Vista, what can I say, it works for me and I hate up grading, I've even moved across PCs and installed it again and again.

I use superantispyware, which is normally great, and warned of IE getting a home page change, but didn't help with FF.

I'm guessing I got this, as mentioned above ,with Free FLV converter. This is annoying firstly because I need an FLV converter, and this works, but really because I've used it for ages with no problems, it must have come when I upgraded to a newer version, like I say I'm pretty careful about this stuff, so it did unroll in quite a sneaky manner.

more options

A good converter is Quick Media Converter which will convert anything to practically anything else:

more options

Thanks for all this help, and the advice on a converter. Checked again today, all traces of plasmoo seem gone.

more options

That seems to have been a very persistent hijacker to have added all those settings to about:config.

Anyway, please be careful when you install something. Most of these 'extras' appear as bundled software which earns the developer revenue when you 'agree' to installing it because you were too busy clicking "Next" to notice. I've attached a screenshot of what Winamp wants you to do when you install it for example. If you don't uncheck the boxes, you get a lot of useless stuff and a new 'search engine'.

Sometimes, 'permission' to install it will be hidden in the EULA and it's well worth hitting CTRL+A to highlight all the terms and then CTRL+V to paste it into Word(pad) so that you know what you're getting into.

more options

It may have come from here judging by user comments on this site:

more options

To uninstall Plasmoo from Firefox follow the steps: - launch Firefox; - go to Tools -> Add-ons -> Extensions -> select Plasmoo Search and press the button Uninstall; - restart Firefox. Your default Web Search and Home Page will be restored.