Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How to stop the cursor from jumping to the address bar with a new tab?

  • 3 replies
  • 0 have this problem
  • 1 view
  • Last reply by cor-el

more options

Hello, "How to stop the search from jumping to the address bar when typing on Firefox Home" was closed, but not resolved. I use DuckDuckGo as my home page and new tab page. It is annoying to have to click on the search field that I want to use. Using the address bar puts a slight strain on my neck.

One excuse from SeanaMuigean in the aforementioned article (1334131) is that all of the other search engines are doing it. My guess is that they do this because it allows the browser to track one's searches. If Firefox is doing this it seems like a very large issue.

I have set awesomebar to False and that seemed to work for a while but no longer. (Not so awesome to me)

Please make it so that a new tab makes the cursor jump to the expected field.

Thank you, Rod Carroll

Hello, "How to stop the search from jumping to the address bar when typing on Firefox Home" was closed, but not resolved. I use DuckDuckGo as my home page and new tab page. It is annoying to have to click on the search field that I want to use. Using the address bar puts a slight strain on my neck. One excuse from SeanaMuigean in the aforementioned article (1334131) is that all of the other search engines are doing it. My guess is that they do this because it allows the browser to track one's searches. If Firefox is doing this it seems like a very large issue. I have set awesomebar to False and that seemed to work for a while but no longer. (Not so awesome to me) Please make it so that a new tab makes the cursor jump to the expected field. Thank you, Rod Carroll

All Replies (3)

more options
  1. In a new tab, type about:config in the address bar and press Enter/Return. Click the button accepting the risk.
  2. In the search box in the page, type or paste handoff and pause while the list is filtered
  3. Double-click the browser.newtabpage.activity-stream.improvesearch.handoffToAwesomebar preference to switch the value from true to false.
more options

Please see previous. "I have set awesomebar to False and that seemed to work for a while but no longer. (Not so awesome to me)"

more options

Maybe look at this extension as that has a setting to set focus to the webpage area.