Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

A few problems with Link Preview?

  • 5 ŋuɖoɖowo
  • 25 masɔmasɔ sia le wosi
  • 11 views
  • Nuɖoɖo mlɔetɔ tres_magique

more options

Before I say anything, let me preempt you: I am aware of the Status4Evar addon. I've found the only thing I use the status bar for is for link previews, when I hover over a link... Which, and you can correct me if I'm wrong, is still built into Firefox.

That said, I've found two problems:

  1. Links will truncate after a certain length and wind up with [first part]...[end part]. This seems to happen when the link preview goes over 50% of the width of the window -- is it possible to customize this so it uses the entire width of the window?
  2. When the find dialogue is open, the link preview seems to dissapear. That was my first thought, but then I realized it floats to the right -- which is strange. Is it possible to make the link preview appear on the left... always?

---

I noticed on this help topic status, "When you mouse over a link, a preview of the URL popups at the bottom left side of the page."

But it doesn't mention anything about links being truncated at 50% of page width, or the preview mysteriously moving to the right of the page...

Before I say anything, let me preempt you: I am aware of the [https://addons.mozilla.org/firefox/addon/235283 Status4Evar] addon. I've found the only thing I use the status bar for is for link previews, when I hover over a link... Which, and you can correct me if I'm wrong, is still built into Firefox. That said, I've found two problems: # Links will truncate after a certain length and wind up with [first part]...[end part]. This seems to happen when the link preview goes over 50% of the width of the window -- is it possible to customize this so it uses the entire width of the window? # When the find dialogue is open, the link preview seems to dissapear. That was my first thought, but then I realized it floats to the right -- which is strange. Is it possible to make the link preview appear on the left... always? --- I noticed on this [http://support.mozilla.com/en-US/kb/what-happened-status-bar help topic] status, "When you mouse over a link, a preview of the URL popups at the bottom left side of the page." But it doesn't mention anything about links being truncated at 50% of page width, or the preview mysteriously moving to the right of the page...

tswaters trɔe

Ŋuɖoɖo si wotia

You can also edit the userChrome.css to force the Link Preview to always appear on the left. Just add the following lines:


statuspanel[mirror]:-moz-locale-dir(ltr), statuspanel:-moz-locale-dir(rtl):not([mirror]) {
 left: 0px !important; 
 right: auto !important;
}

.statuspanel-label:-moz-locale-dir(rtl):not([mirror]), .statuspanel-label[mirror]:-moz-locale-dir(ltr) {
 border-left-style: none!important;
 border-top-left-radius: 0em!important;
 margin-left: 0em!important;

 border-right-style: solid!important;
 border-top-right-radius: 0.3em!important;
 margin-right: 1em!important;
}


I hope this helps. It works great for me.

Xle ŋuɖoɖo sia le goya me 👍 2

All Replies (5)

more options

I have a similar annoyance with the Link Preview: the darn preview covers up auto-find (as you type) results. When you start typing and it scrolls the page up it only scrolls just enough to put the resulting found-word in the very bottom of the screen. The link preview then pops up and covers the result. They did some changes, I think with moving the preview over to the right but that doesn't take affect when you are using Ctrl-G to find again. The issue also seems to stem from the fact that when you search for a word and it is a link, it brings up the link-preview for that link, even if you aren't pointing the mouse at it.

I added a screen capture, but you don't see the mouse pointer being off to the right and above. And many websites or links are much longer than the ones here, apparently; only part of 'Features' (the searched for word) shows up as obscured. (Actually a good thing, because you can see that it is the highlighted word, I guess.  :))

more options

Check out this lifehacker article on how to make the link target display display show the full url: http://lifehacker.com/#!5786727/stop-firefox-4-from-trimming-url-previews-in-the-status-bar

I'm sorry, but I can't help you on your other problems, I personally have the status text and the link display in the addon bar.

more options

Thank you both very much for the responses... this gave me enough keywords to find more information. Here's the bugzilla context:

I added the statuspanel hack to userChrome.css and this does the trick on only using 50% of the width. But the other one seems to do this thing "mirror"ing thing which I don't think I can overwrite with CSS.

So, for me, when a link is being hovered over at the very bottom of the screen, where the statuspanel would come up, the statuspanel mirrors to the right... this is to be expected with a hiding statuspanel.

But when findbar comes up, it's making the viewport just a little bit smaller -- and also makes the statuspanel always mirror right.

With the reduced viewport, the statuspanel really only needs to mirror when a link is being hovered at the bottom of the page --- which it already does when findbar is closed?

more options

Ɖɔɖɔɖo si wotia

You can also edit the userChrome.css to force the Link Preview to always appear on the left. Just add the following lines:


statuspanel[mirror]:-moz-locale-dir(ltr), statuspanel:-moz-locale-dir(rtl):not([mirror]) {
 left: 0px !important; 
 right: auto !important;
}

.statuspanel-label:-moz-locale-dir(rtl):not([mirror]), .statuspanel-label[mirror]:-moz-locale-dir(ltr) {
 border-left-style: none!important;
 border-top-left-radius: 0em!important;
 margin-left: 0em!important;

 border-right-style: solid!important;
 border-top-right-radius: 0.3em!important;
 margin-right: 1em!important;
}


I hope this helps. It works great for me.

more options

@DavidFichtmueller Thanks for the solution; the preview shows on the left, even when the Find bar is up. *However* anyone notice the strobe effect that happens when your cursor gets in the way of the preview? Perhaps there could be away to keep the right-side preview for only special occasions...?