Lesezeichen können nicht geändert, hinzugefügt oder gespeichert werden

Firefox Firefox Zuletzt aktualisiert: 10/18/2021 15% der Nutzer finden dies hilfreich

Dieser Artikel zeigt Lösungsmöglichkeiten, wenn Sie keine neuen Lesezeichen hinzufügen oder Änderungen an vorhandenen Lesezeichen vornehmen können.

Hinweis: Wenn Sie bisher Ihre Lesezeichen ohne Probleme speichern konnten, diese nun aber verschwunden sind, lesen Sie den Artikel Verlorene Lesezeichen.

Lesezeichen können nicht hinzugefügt oder geändert werden

Wenn Sie keine neuen Lesezeichen hinzufügen können oder wenn Änderungen, die Sie an der Symbolleiste vorgenommen haben, nach einem Neustart nicht mehr vorhanden sind, lesen Sie den Artikel Symbolleisten werden immer zurückgesetzt.

Können Sie keine neuen Lesezeichen hinzufügen oder die an Ihren Lesezeichen vorgenommenen Änderungen werden nicht übernommen und Sie verwenden eine Firefox-Erweiterung für Lesezeichen (z. B. zum Synchronisieren von Lesezeichen), folgen Sie der Anleitung im Artikel Beheben von häufigen Firefox-Problemen mit Erweiterungen, Themes oder Hardwarebeschleunigung. Dort können Sie feststellen, ob eine Erweiterung das Problem verursacht.

Lesezeichen können zwar hinzugefügt bzw. geändert werden, sind aber nach einem Neustart von Firefox nicht mehr vorhanden

Wenn Sie zwar Lesezeichen hinzufügen, löschen, sortieren und andere Änderungen an den Lesezeichen vornehmen können, diese allerdings nach einem Neustart wieder verloren gehen, versuchen Sie folgende Lösungen.

Wir empfehlen Ihnen, alle Erweiterungen, die etwas mit Lesezeichen zu tun haben, mithilfe dieser Anleitung zu deaktivieren, bevor Sie mit den nachstehend beschriebenen Lösungsvorschlägen fortfahren.

Lesezeichen-Datei reparieren

Wenn Ihre Änderungen an den Lesezeichen nach einem Browser-Neustart nicht wirksam sind, ist möglicherweise die Lesezeichen-Datei schreibgeschützt. Eine schreibgeschützte Datei kann nicht geändert werden, weshalb Firefox Ihre Änderungen an den Lesezeichen nicht speichern kann.

Erlauben Sie Firefox, Ihre Lesezeichen-Änderungen zu speichern:

  1. Öffnen Sie Ihren Profilordner:

    • Klicken Sie auf die Menüschaltfläche menu button de fx89, klicken Sie auf Hilfe und wählen Sie Weitere Informationen zur FehlerbehebungWählen Sie im Menü Hilfe die Schaltfläche Weitere Informationen zur Fehlerbehebung, um den Tab mit den Informationen zur Fehlerbehebung zu öffnen.
    • Klicken Sie unter Allgemeine Informationen neben dem Profilordnerverzeichnis auf Ordner öffnenIm Finder anzeigenVerzeichnis öffnen. Danach öffnet sich ein Fenster mit Ihrem Profilordner. Danach öffnet sich Ihr Profilordner.
    Hinweis: Falls es Ihnen nicht möglich ist, Firefox zu starten oder mit ihm zu arbeiten, folgen Sie der Anleitung Mein Profil finden, ohne Firefox zu starten.

  2. Beenden Sie Firefox vollständig: Klicken Sie auf die Menüschaltfläche menu button de fx89 und wählen Sie Beenden.Klicken Sie auf das Firefox-Menü am oberen Bildschirmrand und wählen Sie Firefox beenden.
  3. Klicken Sie mit der rechten Maustaste auf die Datei places.sqlite und wählen Sie Eigenschaften, um das Eigenschaften-Fenster zu öffnen.
  4. Gehen Sie im Eigenschaften-Fenster zur Registerkarte Allgemein. Stellen Sie sicher, dass dort im Bereich „Attribute:“ KEIN Häkchen neben Schreibgeschützt gesetzt ist.
    bb29d660686072d5ee243afab05c6bfa-1261244397-722-1.png
  1. Öffnen Sie Ihren Profilordner:

    • Klicken Sie auf die Menüschaltfläche menu button de fx89, klicken Sie auf Hilfe und wählen Sie Weitere Informationen zur FehlerbehebungWählen Sie im Menü Hilfe die Schaltfläche Weitere Informationen zur Fehlerbehebung, um den Tab mit den Informationen zur Fehlerbehebung zu öffnen.
    • Klicken Sie unter Allgemeine Informationen neben dem Profilordnerverzeichnis auf Ordner öffnenIm Finder anzeigenVerzeichnis öffnen. Danach öffnet sich ein Fenster mit Ihrem Profilordner. Danach öffnet sich Ihr Profilordner.
    Hinweis: Falls es Ihnen nicht möglich ist, Firefox zu starten oder mit ihm zu arbeiten, folgen Sie der Anleitung Mein Profil finden, ohne Firefox zu starten.

  2. Beenden Sie Firefox vollständig: Klicken Sie auf die Menüschaltfläche menu button de fx89 und wählen Sie Beenden.Klicken Sie auf das Firefox-Menü am oberen Bildschirmrand und wählen Sie Firefox beenden.
  3. Wählen Sie die Datei places.sqlite.
  4. Wählen Sie in der Menüleiste das Menü Datei und gehen Sie zu Informationen. Das Informationsfenster zur places.sqlite wird geöffnet.
  5. Entfernen Sie im Informationsfenster zur places.sqlite das Häkchen neben Geschützt.
    bb29d660686072d5ee243afab05c6bfa-1266068818-524-1.png
  1. Öffnen Sie Ihren Profilordner:

    • Klicken Sie auf die Menüschaltfläche menu button de fx89, klicken Sie auf Hilfe und wählen Sie Weitere Informationen zur FehlerbehebungWählen Sie im Menü Hilfe die Schaltfläche Weitere Informationen zur Fehlerbehebung, um den Tab mit den Informationen zur Fehlerbehebung zu öffnen.
    • Klicken Sie unter Allgemeine Informationen neben dem Profilordnerverzeichnis auf Ordner öffnenIm Finder anzeigenVerzeichnis öffnen. Danach öffnet sich ein Fenster mit Ihrem Profilordner. Danach öffnet sich Ihr Profilordner.
    Hinweis: Falls es Ihnen nicht möglich ist, Firefox zu starten oder mit ihm zu arbeiten, folgen Sie der Anleitung Mein Profil finden, ohne Firefox zu starten.

  2. Beenden Sie Firefox vollständig: Klicken Sie auf die Menüschaltfläche menu button de fx89 und wählen Sie Beenden.Klicken Sie auf das Firefox-Menü am oberen Bildschirmrand und wählen Sie Firefox beenden.
  3. Wählen Sie die Datei places.sqlite.
  4. Klicken Sie mit der rechten Maustaste auf die Datei places.sqlite und wählen Sie Eigenschaften, um das Eigenschaften-Fenster zu öffnen.
    • GNOME: Gehen Sie im Eigenschaften-Fenster zur Registerkarte Zugriffsrechte. Stellen Sie sicher, dass Ihr Benutzerkonto Schreibrechte für diese Datei besitzt.
    • KDE: Gehen Sie im Eigenschaften-Fenster zur Registerkarte Berechtigungen. Stellen Sie sicher, dass Ihr Benutzerkonto Schreibrechte für diese Datei besitzt.

Eine neue Lesezeichen-Datei erstellen

Lesezeichen und die Chronik sind im Firefox-Profilordner in der Datei places.sqlite gespeichert. Wenn es mit dieser Datei ein Problem gibt, dann gehen bei jedem Neustart von Firefox Ihre Änderungen an den Lesezeichen verloren. Sie können Firefox dazu bringen, eine neue places.sqlite zu erstellen, indem Sie die bestehende Datei umbenennen oder löschen.

Sie sollten diese Anleitung ausdrucken oder in einem anderen Browser öffnen, da Sie Firefox schließen müssen, um die Datei zu löschen oder umzubenennen.

Warnung: Sobald Sie die Datei places.sqlite löschen, verlieren Sie Ihre gesamte Surf-Chronik. Firefox speichert nämlich nur eine einzige Version der Surf-Chronik und es gibt keine automatischen Backups Ihrer Surf-Chronik (wie bei den Lesezeichen).
  1. Öffnen Sie Ihren Profilordner:

    • Klicken Sie auf die Menüschaltfläche menu button de fx89, klicken Sie auf Hilfe und wählen Sie Weitere Informationen zur FehlerbehebungWählen Sie im Menü Hilfe die Schaltfläche Weitere Informationen zur Fehlerbehebung, um den Tab mit den Informationen zur Fehlerbehebung zu öffnen.
    • Klicken Sie unter Allgemeine Informationen neben dem Profilordnerverzeichnis auf Ordner öffnenIm Finder anzeigenVerzeichnis öffnen. Danach öffnet sich ein Fenster mit Ihrem Profilordner. Danach öffnet sich Ihr Profilordner.
    Hinweis: Falls es Ihnen nicht möglich ist, Firefox zu starten oder mit ihm zu arbeiten, folgen Sie der Anleitung Mein Profil finden, ohne Firefox zu starten.

  2. Beenden Sie Firefox vollständig: Klicken Sie auf die Menüschaltfläche menu button de fx89 und wählen Sie Beenden.Klicken Sie auf das Firefox-Menü am oberen Bildschirmrand und wählen Sie Firefox beenden.
  3. Löschen Sie im Firefox-Profilordner die Datei places.sqlite-journal und – sofern sie existiert – auch die Datei places.sqlite-journal oder benennen Sie sie um (z. B. places.sqlite zu places.sqlite.old, um sie als Sicherung zu behalten).
  4. Optional: Löschen Sie außerdem die Datei xulstore.json. Beachten Sie bitte, dass dadurch alle von Ihnen vorgenommenen Änderungen an der Symbolleiste rückgängig gemacht werden und Sie diese Änderungen danach neu erstellen müssen.

Beim nächsten Start erstellt Firefox eine neue Datei places.sqlite und importiert automatisch die zuletzt gespeicherte Lesezeichen-Sicherungsdatei. Ihre Lesezeichen werden also wiederhergestellt, Ihre Surf-Chronik wurde aber gelöscht und ihr Inhalt bleibt verloren. Bitte beachten Sie, dass Ihre Surf-Chronik auch für die Funktion Autovervollständigungs-Auswahlliste in der Adressleiste verwendet wird.


Basiert auf Informationen des Artikels Bookmarks not saved (mozillaZine KB)

War der Artikel hilfreich?

Bitte warten…

Diese netten Menschen haben geholfen, diesen Artikel zu schreiben:

Illustration of hands

Mitmachen

Vergrößern und teilen Sie Ihr Fachwissen mit anderen. Beantworten Sie Fragen und verbessern Sie unsere Wissensdatenbank.

Weitere Informationen