Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

updating Firefox for MAC G5 X.5 non Intel, and also with Intel -core 2 duo (non x86?).

  • 1 cavab
  • 5 have this problem
  • 1 view
  • Last reply by James

more options

Dear Firefox and Mozilla,

          My wife has a MAC G5  10.5.8  Power PC. She gets upgrade messages from you and can not contact you, as some smartypants has a popup that says she can't until she upgrades.   Probably because she doesn't have the INTEL core,  she can not download the latest Firefox.   Will you be supporting non Intel?

I have an Intel Core 2 Duo on my MAC G5 MacBook......not the x86??, and have Firefox 8.0.1.....which seemed not to like me at the 7.0 download. Are there issues or considerations that I should be aware of?

Thank you for your time and help. We appreciate the work that goes into having Firefox here for us.

Garfield Barnes

Dear Firefox and Mozilla, My wife has a MAC G5 10.5.8 Power PC. She gets upgrade messages from you and can not contact you, as some smartypants has a popup that says she can't until she upgrades. Probably because she doesn't have the INTEL core, she can not download the latest Firefox. Will you be supporting non Intel? I have an Intel Core 2 Duo on my MAC G5 MacBook......not the x86??, and have Firefox 8.0.1.....which seemed not to like me at the 7.0 download. Are there issues or considerations that I should be aware of? Thank you for your time and help. We appreciate the work that goes into having Firefox here for us. Garfield Barnes

All Replies (1)

more options

As of Firefox 4.0 and newer only the Intel is supported as the PPC was dropped and 64-bit was put in place with the 32-bit version.

For PPC Macs there is two options. Either you can use the current 3.6.* version from http://www.mozilla.org/en-US/firefox/all-older.html

Or you can try a third-party version of Firefox 8.0 from http://www.floodgap.com/software/tenfourfox/

However do see http://code.google.com/p/tenfourfox/wiki/PluginsNoLongerSupported if you use this version.